Ltc in a native segwit wallet on ledger, having hard time transferring it out

I’m trying to transfer out some ltc from my wallet on ledger. I accidentalyl set up a native segwit wallet and when i try to transfer it, it says verification will take a long time because i have a lot of coins… I’m only trying to take out 3 ltc. can anyone help with how i can make this work?

https://electrum-ltc.org/ I would use the electrum wallet for litecoin. Use your Ledger hardware wallet with it. I had the same problem with bitcoin native segwit accounts on Ledger Live and had success with electrum for bitcoin.

2 Likes

trying this and now i ran into the issue of my ledger not letting me confirm the transaction. I think my ledger is not registering that i’m trying to send? I updated it and everything. Not sure what to try now.

I was sending ltc from a Legacy address/wallet to a native segwit wallet. Is that the reason why i cant get it to work?

sending from Legacy to native segwit should not be a problem. Are you attempting from Ledger Live app or Electrum? You have some other options. If you put your seed words you use on your Ledger device into another wallet that uses same type of seed words like a Trezor you can access that way. You can also export your private keys out of your Ledger device and use them in another wallet that allows you to import private keys.

2 Likes

ooo okay. thanks! I’vebeen getting stuck on the “Confirm your transaction on ledger” but my ledger doesn’t show anything. Would what you just said help bypass this?

ive tried clearing cache, repatching ledger, and using electrum.so far none of these have worked.

Have you tried the electrum wallet? Or are you still trying on the Ledger app? Also, maybe try a different USB cable it it isn’t working correctly. Also, reboot your computer might make a difference.

2 Likes

Another issue, try closing the Litecoin app on your ledger and then opening it again. Sometimes I have to do that so the device is recognized.

2 Likes

Do you have another device you can try with the seed words in the device not working? You can also export your private keys and use them in another wallet. It sounds like the trouble is with the device if nothing is working with it. Is it nano s or nano x. If it is nano x, is your battery level OK?

2 Likes

hmm i’m trying with the electrum wallet connected to the ledger. I’m currently able to send and receive other coins using ledger live, just not the ltc. not working on electrum right now either.

Try deleting your LTC app in Ledger Manager and reinstalling it. The LTC app has to have the BTC app installed for it to work right. The problem could be in the BTC app as well. Might reinstall it also.

2 Likes

kk. trying that now. Thanks again Michael! Now i’m waiting for it to sync

Get it solved?

Hey Michael, Not yet. It’s still synchronizing. i’ll be trying on a few other devices later today when I get home from work! i’ll let you know as soon as I try

still doesnt work

I would try to enter your seed words into a different hardware wallet., either another nano or a trezor. Another option is to try this program: BIP39 - Mnemonic Code You can use it for whatever coin you want.You should run this program when your computer is offline. Enter your seed words, select the coin and derivation path. It will give you your private and public keys, addresses, etc. Your first LTC address will have derivation path ending in 0, LTC 2 would end in 1, etc. I tried this once with my BTC seeds and it gave me the same addresses that my nano did. Once you have your private keys you can import them into many different LTC wallets to access your coins. Uncheck the box for Prefixes for LTC use.

2 Likes

I just downloaded version 4.0.9.3 Electrum-LTC from: https://electrum-ltc.org./ , I made a wallet from a nanoS that had a legacy LTC address, I was able to load previous transactions and sign a transaction without any trouble. . To build your wallet go to file, New / Restore, Standard wallet, Use a hardware device, it should show your device, if it doesn’t click back, reload LTC app, try again, once it sees device click next, then select legacy, p2sh-segwit, or native segwit. The derivation path is set below that. path ending in zero will produce your LTC 1, path ending in 1 will give you LTC 2, path ending in 2 gives LTC 3. This should work unless your device is defective.

2 Likes

Hey Michael, I appreciate that you spent so much time helping and I apologize for not answering. I’ll try your solutions and let you know. I was a bit frustrated with work and didn’t have the bandwidth to deal with this before but now i do. Thanks again sir