L3+ solo mining on a home network


I hooked up solo again and I remember why I thought I did it with bfgminer…its because I used cgminer as the proxy and I was long polling…

I made this post with this configuration file layout a few months back and your right I did not use bfgminer as a proxy server…also I was using Linux to run my miners to cgminer proxy on windows with some gridseeds…sorry for forgetting that and causing a mix up…


All good, it used to be so universal, as you know. You could go to 5 year old guides but you really just cant now unfortunately :frowning:

Just out of curiosity though, what arguments are you giving cgminer to use it as a proxy stratum>getwork?


I don’t exactly remember sorry


Thats the spirit, thanks for looking into it though. I’m always curious to try new things and i just couldn’t find anything in cgminer documentation to support it. He also stopped supporting scrypt awhile back. These bitcoin gurus right?!


Hi Trix,

Would you be able to help me with this? I tried to follow instructions mentioned to configure the server for solo-mining but was stuck at one of the steps.



Whats step?


Could you please help me to setup a antminer l3+ for solo-mining ? Thank you very much


Everyone trying to setup CoiniumServ suggested by @Trix be aware that currently does NOT work with the most profitable coins by the Scrypt algorithm. The only use case might be mining Litecoin. In that case I recommend you have multiple AntMiners L3+ if you want to solo mine LTC otherwise you might not find any blocks for a while.
Coins with known issues:


Thats miss-information im afraid. I quite clearly say many times as does the repository that it is pool code. Meaning it is and can be used to mine any scrypt coin. It can even be used to mine other algos if you have the know how. (Not using the L3+ tho as it is scrypt asic of course)
It is the only public way to solo mine using the L3+
There is even a list of pre configured files to use (digibyte) right out of the box!


If there is a open issue #676 where I read “Coinium is not submitting the blocks correctly.” for the coin Digibyte, I don’t see why the same code should work differently for me. Either way, I used the configuration file (digibyte.json) but seems that does not work, at least I tried to set it up with my limited knowledge and didn’t work.


Just some FYI stuff because reading half of this made me buggy… if someone farther down already put this up… sorry… I couldn’t go any farther without saying something:
Been digging around the firmware for the l3+ : Soooo here is the thing. antminers USED to be able to mine solo, no sweat… the newer ones however have some issue with curl (which is needed for getblocktemplate etc…) anyway the only way to compile the cgminer without major glitching is to disable curl with ./configure options :side note: the bfgminer thing … well newer cgminers and bfgminer HATE one another (not sure why on that one) best bet is to do your own home-brew pool… and while I love alot of the feature in coiniumserv there is… umm tons of issues with most coins.
So anyway, I’m working on a way to get curl to work right with the newer cgminer used in things like the l3 and d3 (not 100% on the s9 as I do not have one to test with) For the guy giving instructions on the how to mine solo bit earlier… sure man all your advice would work great for anyone who was using a miner that was say usb connected or something like that… but with the l3’s etc… most people aren’t going in and running cgminer by hand so your command line settings just won’t work for them… they could edit it in, but without redoing the firmware every time it reboots it will be back to where it was. - okay my vent is done… back to work for me. :slight_smile: that will tech me to read things while waiting for a blockchain to download. hahaha.


I can attest that this has been the only successful way I have found so far. I appreciate your link and although it took quite a while to wade through every step and then eventually work all the bugs out (my configuration bugs), I have it up and running solo mining with an L3+ as well as some other USB ASIC’s.

I have many more things to iron out such as why the hash rate reported is so far off, solve a block to make sure it is actually working properly (fairly certain it is), and so on …


I can say ditto to this comment. I also have CoiniumServ up and running with similar results. The last issue I’m trying to solve now is how to point my miners to the correct url. In the admin section of the L3 I’m pointing to “stratum+tcp://{myurl}:port” but CoiniumServ still says “Broadcasting new job 0x to 0 subscribers…”. Any suggestions @arebias? My stratum configuration is bound to Could this be because I have my server hosted on Microsoft Azure vs on local computer?


Perhaps. Try this command and lmk what you get:

telnet IP PORT


telnet 3334

You should see output like this:

Connected to
Escape character is '^]'.

That will confirm that you’re network setup on Azure is working out OK.


Thanks @nehgekim . That worked as expected. But I still can’t seem to connect. Maybe I’m misreading the message outputs. I have some errors, but they seem to “clear up”. For instance it complains about not being able to start Stratum, but then says it’s listening. So I assumed that’s just because I started CoiniumServ while it was already listening.


Reboot, start fresh.

Check what’s running on that port with:

netstat -nlp


Great idea. Yea I killed the previous process and restarted. So that eliminated all of the errors except:

Error getting account for pool central wallet address

Gonna try to track this down. Thanks again @nehgekim Let me know if you have any extra suggestions


Just keep reading the logs like you’re doing, eventually you’ll get it


Sorry I have been so late responding but I dropped the CoiniumServ project since I ran into stumbling blocks. Although I did have it up and running locally I was not able to fully test the production value since my Windows firewall(s) - router - is just a mess and no matter what I did I could never seem to be able to open access for others so that I could finally see a block mined and test the full results (i.e. … Payments, etc…)

Since I abandoned that I moved to a VPS and began working on pretty much every single open source stratum pool/solo mining solution available (including CoiniumServ) and after many headaches I finally got UNOMP up and running on the VPS and it seems to be working properly. however I will not know that for sure until a block is solved and I see the notification and payout perform properly.

With just me, it might take a week or more to solve a block (then again maybe an hour - never can tell) but as soon as I do then I will know more as to whether this set up is working correctly.

The interface and essentially everything has been left untouched up to this point and I do not think I will be making any further modifications until a block is solved and it is fully tested. It can be found at this moment at mine2pool.com:3032 for Varr Diff

example: bfgminer.exe --scrypt -o stratum+tcp://mine2pool.com:3032 -u YourDigibyteWalletAddress -p x -S MLD:all --set MLD:clock=600

That is with BFGMiner and a Moonlander2 USB ASIC. The L3+ would be:

stratum+tcp://mine2pool.com:3032 -u YourDigibyteWalletAddress -p x

I am going to point my Antminer over there in just a few minutes and see if it works out ok.

Regardless, I can only assume that there would be no (or little) difference in using UNOMP vs CoiniumServ as a solo mining platform if you set either of them up to receive 100% of the payout from blocks discovered. Not entirely sure though since I am not a developer and stumble through all this stuff as my age is catching up to me. 50+

Anyway, just another option available I would think. BTW; I loosely followed this tutorial on how to set up UNOMP and although I had to do a hell of a lot of trial and error on Ubuntu builds, libraries, etc… I finally came up with a so far solid working beta using Ubuntu 14.04 LTS

Hope that might help someone.

BTW:, The web page for my setup right at this moment is mine2pool.com:8080 - Until I fix that later.


@arebias Thanks for the feedback. It’s funny you mention UNOMP, I actually abandoned CoiniumServ for UNOMP a couple of days ago and I now successfully have a pool running for litecoin, digibyte, and verge. It was a lot more straight forward in my opinion. I’m a little biased because I’m a Senior Software Developer with tons of experience in Javascript/Node, so it was more up my ally than CoiniumServ. So now it’s on to understanding minimum diff, max diff, other pool settings…etc.