L3+ solo mining on a home network


I was trying to help someone without knowing what they are using or scripts they are typing…I was trying to help someone by offing advice on what they could try…

…he already knew I dont have the same equipment he does…

looks to me like I have given the most usable advice on this thread so far

I really dont give a ■■■■ what you think anyways

I mine solo with bfgminer proxy server with no issues at all so you can kiss my ass sir!!!


I said earlier that i also appreciate your willingness to help however, i think i’m within my right to also state that i encourage you to re-think what “help” is sometimes. Take that how you will. Im only going off your post history.

Don’t let this set you back in regards to helping people though. Its not my intent to stifle that willingness. I encourage you to try to stick to what you know. For your information, since “anyway” is an adverb, it is impossible for adverbs to be plural.

You may solo mine with bfgminer proxy however, its not on a l3+.

Link to a solution: L3+ solo mining on a home network


Well, I tried that as well, but I guess I was being a bit to obtuse in my reference to -coinbase-addr, which is to say that neither that nor --coinbase-addr is an acceptable argument in the current version of bfgminer. So I did attempt the code above without the -coinbase-addr (altcoinaddress), and after starting, it came back a few seconds later telling me that either the url, user, or password was invalid. I double, triple, etc checked, and tried a couple other things with no go.


I wasn’t ignoring you, it was just that you were not posting any code that I could try to get my L3+ to solo mine a Scrypt altcoin with, whereas bakd247 was. That being said, it looks like you now have a working solo mining operation on a Windows Box with the L3+, so I’d like to see if I can get what you’ve got working on my windows box.

I downloaded the zip file you linked to. I also downloaded the community version of Visual studio, and installed it. Now I am stuck, since I don’t actually know how to get from the download of those files to “Make sure you note that the column on the right in the guides picture, etc”.

I have never worked with Visual studio, and didn’t see any obvious file I should be clicking on in the CoiniumServ unzipped folder that would allow me to compile it.

Do I need to open Visual studio, and click on a build tab up top and click build, what happens then, which file in the CoiniumServ folder to I point to that I want to build??


Funny, I figured I’d do a quick search to see if I couldn’t figure out how to compile CoiniumServ, as it is probably a common question, and I stumbled upon bonesoul/CoiniumServ. And while reading through it, I figured I should look back to see what you were saying, when I noticed that you linked to the same how to build CoiniumServ article.

So based on that, I’m going to assume that I am to build it in release mode?

Assuming I am able to build it, which seems fairly straightforward based on the how to guide, the next question would be, “how to make a pool config”?

And once the pool config is done, how do I start my altcoin wallet (do I need to start it in server mode, etc). And where do I direct my L3+, I assume I direct it to the computer running CoiniumServ and the altcoin Wallet? Do I need to input the coin address in the L3+ user spot?


This is all in the wiki in the link i posted when i gave the solution the first time
click here:


Once you got the sources, you can compile on Windows using Visual Studio. First navigate to sources folder and open the CoiniumServ.sln in build\ folder.

Set build mode to either Debug or Release though you are advised to use Release mode for production environments. Use the Build ~ Build Solution (F6) menu to start compiling the sources.

You can find the executables in either bin\Release or bin\Debug folder (based on the mode you selected).

Then you have to configure the server to get it working.


The answers are all in their wiki but if you want me to quickly run you through it all (im quite willing to do it) then please come to the discord server i linked you in private message on this forum, thanks.


–generate-to (address is the argument for the newest version of bfgminer…my bad I still use an older version

there is a list of the commands at the bottom of this page:https://github.com/luke-jr/bfgminer

you can also start bfgminer like this from command prompt to see all available arguments and options:
bfgminer --help

seems like you need to change a lot for bfgminer to work for you

–api-allow Allow API access (if enabled) only to the given list of [W:]IP[/Prefix] address[/subnets]
This overrides --api-network and you must specify if it is required
W: in front of the IP address gives that address privileged access to all api commands
–api-description Description placed in the API status header (default: BFGMiner version)
–api-groups API one letter groups G:cmd:cmd[,P:cmd:*…]
See README.RPC for usage
–api-listen Listen for API requests (default: disabled)
By default any command that does not just display data returns access denied
See --api-allow to overcome this
–api-mcast Enable API Multicast listener, default: disabled

Username Trix claims you can mine solo by setting up Chromium as a proxy server using java code too


Save yourself the trouble.


BFGMiner supports solo mining with any GBT-compatible bitcoin node (such as
bitcoind). To use this mode, you need to specify the URL of your bitcoind node
using the usual pool options (–url, --userpass, etc), and the --generate-to
option to specify the Bitcoin address you wish to receive the block rewards
mined. When you run Bitcoin Core on the same computer as your miner, the pool
itself will be automatically configured for you (on the default goal). Please be
aware that solo mining via GBT is at this time only supported for Bitcoin."

I’m really starting to hate this now but you have it so mixed up. Please stop, save yourself the trouble.


I am replying to someone who is asking for my help…not you you "trix"
why dont you try creating a “new post” or sending someone else a message…


Sorry but you’re doing the opposite of helping. I cant make the simple fact any clearer so ill just stop ok. Have at it. Clutter the thread with more “help” that solves nothing. You keep skiming over important facts tho, thats helping!


btw LItecoin-qt is a “getblocktemplate” wallet and bfgminer works fine solo on litecoin…so I dont know where you get your information but its not very up to date


My information literally came from the link you provided https://github.com/luke-jr/bfgminer

It was just a example of the instructions in bfgminer and how old most of it is @bakd247 and thus how old the things you’re trying to suggest are. Im trying to just tell you in so many different ways that you seem to be getting this all a bit confused.

If we are going to keep going on and on in this persons thread can we at least get some things straight?

We need something that will be the middle man because clearly the cgminer code on the l3+ wont work directly with solo mining on a litecoin client. Can we agree on that? If not then what are your thoughts on that?

The only proxy you can see out there only converts gbt to stratum and not the other way around? Can we agree on that? If not then what is your thoughts on that.

We need to find a solution that acts as a middleman to convert stratum (from the l3+) to gbt (what the litecoin client understands) Can we agree on that? If not what are your thoughts?

Where in the bfgminer documentation does it say it converts stratum to gbt and not the other way around?


if you were paying attention you’d see that I said I am using an older version on litecoin first off and that the newest version has changed a lot of stuff…
I am using version 5.0.0 and the newest version on that link is 5.4.2…
GBT stands for “Get Block Template” and is a direct command in litecoin-qt so it should work with qt…but only as a proxy server…

I bet if you set the correct parameters it will connect just fine as a proxy worker assuming you set proxy arguments correctly

Until I get my L3 I can not be of service for a solution …I am just trying to help someone use a proxy server correctly…which is a shot in the dark not knowing what they have or what they are doing themselves…

I find it very very hard to believe that this guy is the only one out there who is trying to mine with an l3 solo and cant get it to work…there were just too many of them sold and every one of them is capable of finding blocks…I also find it hard to believe that your java solution is the only one out there…

“there are thousands of ways to mine all the way down to pen and paper if your willing”…using that as a figure of speech of course

but yes it would be nice if there were a straight forward solution to this as antminer claims to have one for their “antrouter” to run solo with out the need for proxy so why not the l3?


The correct way to connect it to a bitcoin client is to have a bitcoin.conf. That is the only place that bfgminer looks for info on the coin client. You do not input -o -u -p commands for solo mining or to use it as a proxy because it will just loop over and over again. Even in 5.0

The correct way to solo mine using bfgminer as the proxy is

bfgminer --stratum-port 8840

The rest is taken care of in your bitcoin.conf which you can set it to a litecoin client of course.
Furthermore you do not need to set a coin payout address for all coins but you can and sometimes have to. It does not cause a issue if you don’t. Its just to allow bitcoin miners to pay to a address and they can even sign the block with another command but they are old settings and are not necessary for successful solo mining. In saying that though, litecoin has finally added the ability to generatetoaddress. It does not necessarily mean every altcoin can utilise it just yet. Furthermore, most commands sent that it does not understand outside of the template for mining are usually discarded and don’t throw errors. Hense a ton of depreciated arguments usually not effecting mining because they don’t throw errors.

Again, old instructions, not needed and not causing issues that we are facing and trying to solve.

The issue is when the l3+ miner connects to bfg, it will give a error saying

SSM: No usable 2D work upstream!

There is a versioning issue with libbmaker and he has previously stated that the stratum connection is broken in previous versions but i can see its broken in the current also, and previous versions. So no mate, it does not solo mine to a litecoin client using a stratum only miner that the l3+ uses natively, regardless of how old the bfgminer is.

It does not like cgminer and luke does not support anything altcoin.

I agree with you, its hard to believe we are the only ones needing this solution but i can bet your ass that there is no one supporting solo mining with a l3+ scrypt asic. at least not publicly. Besides what we are trying to accomplish.

My solution i posted earlier works and is simple to do with some common sense. I promise to try and get luke from bfgminer to fix this issue but i have to be careful because again, he does not like altcoins and wont support software that enables altcoins to flourish. He is usually motivated by donations though. Time will tell.


Update: i have talked to the creator and maintainer of bfgminer today and confirmed a few things. He said this

[19:02] <@luke-jr> bbb_: confirmed paypal.me/lukedashjr is mine [19:16] <@luke-jr> bbb_: essentially the problem comes down to it being an altcoin.. GBT is designed exclusively for Bitcoin, and doesn't "just work" for altcoins. casinocoin didn't take extra steps to make their GBT work either [19:16] <@luke-jr> since it's just a clone scamcoin, you can probably force it to work by converting the casinocoin address to a Bitcoin address, and manually specifying it to BFGMiner [19:19] <@luke-jr> bbb_: your log has the address CsNxeVJM7GnSh2iyo6zvS5RbkPTVcB26fv ; converting this one to a Bitcoin address, you get 18v55SxHEDountpZ7MfzrZot8GF5mj6ciS [19:19] <@luke-jr> so use --generate-to 18v55SxHEDountpZ7MfzrZot8GF5mj6ciS [19:19] <@luke-jr> I don't know any simple way to do this conversion on Windows

The bfgminer usually automatically creates a address but like he said…

I will test this a bit today, see if it mines blocks then get back to you guys with more info on conversion of the addresses.
I have to pay for this info btw, he does not go near alt coins without payment… Who can blame him though right?!

And no, GBT is not the same as getwork. Ideally we need a stratum>getwork proxy. There just isn’t one for windows besides using that portable pool code i linked to earlier. CoiniumServ. Which might i add, i’m fine with and its a elegant and simple solution. I’m perusing this bfg proxy for completeness.


Update: luke seems to think litecoin wont work at all because its not supported ( he really hates litecoin so it makes sense his software does not support it)

[00:16] <@luke-jr> ie, Litecoin isn't supported

In regards to how to convert the addresses for coins that dont have working GBT (most of them) he says

[00:14] <@luke-jr> to convert the address, you need to change the first byte to 0, and recalculate the checksum
[19:19] <@luke-jr> I don't know any simple way to do this conversion on Windows

There is more and its still not a decent turn key solution once going. i needs lots of fiddling because its really not set to support much in the way of scrypt.

I’m going to post my solution again and leave it there.
You’re welcome and feel free to pm me for help on how to configure the configs and how to turn off things you dont need in CoiniumServ

Tip, dont get git, you dont need it, just download the zip of the project
Then follow this guide below:


Am I correct in thinking that if the CoiniumServ application shows up in the Release folder, that I’ve correctly compiled it?

If that’s correct, then I’m guessing that the reason the program CoiniumServ.exe won’t launch, other than the window opening and quickly shutting, is because I haven’t configured it?

How do I pm you, I’ve been trying to figure that out for a few days, but don’t see any button.


I have private messaged you a few times. Top right button that probably says “C” click it and then click the mail icon.


single (left) click the user name you’d like to message…the click “message”