Antminer L3+ ERROR: Socket connect failed: Connection refused


I have the same problem today, but it’s not a firewall problem. I can ping bitmain just fine and even do Traceroute successfully. The error shows up in the field in the overview section that normally says what the hardware version is. I’m on DHCP, no firewall msgs that I can tell, using an ATT DSL modem/router, again, getting out just fine. Pool configurations are correct, but two were showing dead this morning, so I added a third. Then this happened.




have you tried disabling DHCP and adding the static IP of the miner to the router manually?


Yes, actually. But it pings bitmain just fine, so not a networking problem. In following bitmain’s troubleshooting, seems the controller is not working properly.



try pinging form command prompt manually
open command prompt and type:

then type:
ping (pool address)

do you get pings to the pool and google?

are you using the address format like this?

have you tried using http instead like this:
instead of stratum to see if that solves the issue…if it does then it is a firewall issue…in your router…not a windows firewall issue

I have a miner with a bad controller but I can still get a connection to the pool…just doesn’t solve any shares…
if you can open a command prompt and type ping ip address(of the pool) and you get consistent pings…then it is a firewall issue in your router…if you cant ping the pool from command line then the sites pool server is down…connect to a different pool


I had the same problem, with me I had removed the fan and the Schutzgitte from the front fan the other way around put it back so the fan could not come to the necessary number of revolutions (touring)
Maybe this will help somebody someday

Ich hatte das selbe Problem, bei mir hatte ich die Lüfter abgenommen und das schutzgitte vom vorderen Lüfter anders herum wieder draufgesetzt somit konnte der Lüfter nicht auf die nötige Umdrehungszahl (touren) kommen
Villeicht hilft das irgendwann mal Jemanden