Antminer L3+ ERROR: Socket connect failed: Connection refused


I know the one of the only ways you can enable DHCP is by enabling it manually by logging into your router…


it wont work at all if you set your antminer to a static ip…unless you manually add the device to the router when dhcp is disabled…with the static ip of the device and the mac address…

if you have it set to DHCP on the miner then you need to enable DHCP on your router for the device to connect…
if DHCP is disabled on the router then you need to set the device to a static ip that is within the range of 1-254 (example with comcast router of belkin router…(also make sure DHCP is disabled on the device…this should be the only way to add/edit a static ip to the device)

and add the device to your router manually using the static ip address you assign to it or the one that it is set to on the device and the MAC address


yes I have to add it manually but how do I change is it here


Fill in the blanks…type ipconfig in command prompt to get the settings for the device…
What operating system are you using on your PC?

Also come to think of it…you actually need to enable dhcp with or without static enabled on the device its self…but you still need to add it manually


thank you so much for your help
my system is windows 7
I did what you told me now
and then I do what for the ip address of my antiminer l3 + is visible and can enter the interface of the miner


Hello Friends,
I have the same problem with Antminer D3. Sow me error “Socket connect failed: Connection refused” and the mining status is blank.
I have
-reset te miner - without reuls
-upgrade with new Firmware - without result
-disconnect all hashboard - without result
-change dhcp to static ip - without result.

The miner new and was working 2-3 days and not write me this error.

I need ideas and typs to resolve this problem.

Thank you in advance!



add you miner to your router manually with DHCP (Dynamic Host Connection Protocol) enabled

you need to add the device that has the ip address
according to your pics
since that is what you set the routers ip address to…
you will need your MAC address (media access control address) which you can get from command prompt or terminal with ipconfig in windows or mac and if config in Linux

you should also try setting the ip address to a higher number and then adding it manually…( is the highest number you can go with most routers

if you see it on your router but it doesn’t connect of mine then it is a power issue…not a network connection issue)


Hello bakd247,
I add my miner to the router in “Attached devices” with the IP address of the miner, hostname and MAC Address but again without result. I have other 3 other miners but L3+ witch are adding in the Attached device in the router and work fine but this D3 work only for first 2-3 days and now the miner status is blank.
I set the miner with static ip and with DNS the result is the same.And now I can not understand where can be the problem.


do you have DHCP enabled on your router when you add it?

if it was working and suddenly stopped you should check that there are no power issues…lots of miners will stop mining if the fan is not turning at a high enough rpm…so a lack of power due to too much or too little current may be the issue here

I went through 3 PWM fans on one of my miners before I got one that would turn higher than 2000RPM at minimal speed(which is what i didn’t know I needed at first,as most fans turn at under 2000 rpm)
and the TAC reading ends up being too low to sustain the temp regulation of the miner…have you tried running it on its own circuit breaker?
you could also be having bandwidth issues but i doubt it although I don’t know what type of connection you have…
sound mike either a power failure issue or a router issue one of the two…


Hello bakd247 and thank you for your help.
I check all settings of the miner and of my router and all is right. But when I reset the router from the reset button on the router come the default settings with antpool mining settings and it work but when I write my pool settings does not work. I’ve reset the minter 3-4 and now work the miner and recognize my pool account workers.
Thnak you again for the help! :slight_smile:


I’m having the same problem with my D3 miner, Socket connect failed: Connection refused. It’s on DHCP (router and miner, wired directly). I made a reservation address for the miner under the router LAN settings and checked the attached devices; The miner MAC address says “Allowed”.


Hi All,
We received 3 L3s recently and when we started each… there is no issue is L3. all L3s working fine.
The moment we change anything in the configuration like We changed the pool configuration to point to our pool and we started getting socket connect failed: Connection refused.

We tried by exporting the configuration and change the ccminer.conf file to point to our pool , uploaded modified file. Still not working.

We tried reverting the changed by uploading the backed up(exported) changes and still not working. Only “Perform Reset” is working. Again that is mining for default address.

Please help in this regard.


I created an account just to say thank you and give you my 2 cents.

First things first, I had the ERROR: Socket connect failed: Connection refused
However, mine was on a D3. I looked on every forum I could find. I read every piece of information I could find. All the troubleshooting steps were a bust. I thought to myself, what exactly is the error message saying? Then I had an epiphany.

I installed a larger CFM fan with higher RPM’s (Delta 252CFM). I installed the original fan, and what do you know? The error went away. I feel like a dumbass, but at least I learned something.

Anyway, thank you again!


the D3 does not mine the scrypt algorithm…it is for mining x11 (DASH)

the fan issue made me feel like an idiot on more than one occasion…I have had an issue where the power supply wasn’t putting out enough to turn the fan fast enough to keep the miner running…but it would power everything up so it took me forever to just simply try a different PSU…and my problem was solved…


Just signed up to say thanks. I ran into a similar issue with my router and TrendMicro AiProtect was blocking the L3+ from connecting to the mining pools thinking that it was an infected device on my network.


tengo el mismo problema. solucionaste…?? si alguien puede darnos una respuesta sobre el tema por favor.


have you tried refreshing the page? you are not connected to any pools…enter the correct pool information in the configuration tab…also try a different pool


ingreso el pool de ltecoin de antpool y nada


that’s because you are not typing it correctly…
you need to enter it like this: