Antminer L3+ ERROR: Socket connect failed: Connection refused

This morning when I woke up I found my Antminer L3+ running at idle. When I rebooted the machine via the GUI, it started mining and everything appeared to look good. I changed the mining pool and the miner restarted, and then started rebooting on it’s own. When I logged into the GUI I saw this error: “Socket connect failed: Connection refused” I tried resetting the unit, re-flashing the firmware via the instructions provided on Bitmains’ support page. Nothing worked. It’s been rebooting for hours with the same error. I’ve contacted Bitmain, but who knows when they will respond. The miner is only a week old. Any help is greatly appreciated.

1 Like

This is all that is shown under Miner Status

1 Like

check your firewall and you may need to manually add the miner to your router using the MAC address and the static IP address of the miner

1 Like

Son of a bitch…looks like my router was the problem. For some reason after it’s weekly scheduled reboot it blocked the Antminer. Thanks!

1 Like

Hey I am sorry , how do you configure your firewall?

open your connection /firewall setting and you will find and advanced link that will let you accept or reject connections that are occurring

on your start bar move your cursor over your connection and open connection properties…then click the “Windows Firewall” link
now add the exception to the list of aloud incoming connections…

So it just started working again on it’s own. Super weird.

Service provider may be throttling your connection…they just did that to me while I was downloading bitcoin blockchain and mining on the same network…now that my plan renewed everything connects fine and is way faster…

Those fools. hehe thank you for your help though :slight_smile:

Wow! I created an account in this blog just to confirm that indeed the router blocks a miner. I just got my L3+, had it running for 2 days perfectly fine using DHCP IP address and today I decided to switch to static IP because I have more miners on their way and everything was still fine UNTIL I changed miner settings (pool settings) and APPLIED changes… after this I kept getting SOCKET CONNECT FAILED: CONNECTION REFUSED.

I switched back to DHCP and the error went away right away.

either your dchp is accepting static ips or your miner does not have a static ip address…

my router is set to DHCP and it accepts static IP address with no problem…the idea is to just make sure that DCHP doesn’t assign an IP address to a device that already has a static one so there are no conflicts or collisions…

Other wise you’d have to specify the routes you want the connection to make I am pretty sure…if you are not using DHCP that is…

All my devices were on DHCP so IP conflicts is ruled out. Yes, most likely I could switch back to static and re-configure my router but I’m not in the mood for it. I’m fine using DHCP permanently. Thank you for the suggestion!

Thank you for your Info, this it is usefull for me, too !!!
Was a D3, but the same problem and the same solution !!! Perfect !
Thank you, again !

I have a D3 with the same error. I have tried everything with the network firewall to my knowledge. The problem started when I changed wallet addresses. Now I cant even view the GUI for my miner when I type in its IP address. Any help would be greatly appreciated and will be rewarded if it leads to a solution.

If it happened when u changed your payout address then It has something to do with how your node I setup…u may need to start from command line specifying the new address so that DNS can find your wallet address

I have a l3 + with the same error. The problem started when I changed IP DHCP to static IP it worked fine with the address. Now, I can not even see the GUI for my minor when I type his IP address. please help me.

I have the same problem as you
please tell me how you did to go back to DHCP because I can not even change the interface does not deny access to setings
I need help

login your router manually with the gateway IP address in a browser window…
you may need to add the device to your router manually using the MAC address/Device Address and device default IP address (if it has one, lots of miners do)

(Mac address stands for “Media Access Control Address”)

you can find the MAC address by connecting the device to any PC via USB, Ethernet or WiFi and
in windows command prompt type ipcofig
or in Linux terminal type ifconfig
or in Macintosh/Apple uses ipconfig apparently…then it will show you all connected devices with their IP and MAC address’

you should be able to switch DHCP (Dynamic Host Connection Protocol) manually when you login to your router also

if it connected when you enabled DHCP and does not connect when you disable DHCP then the device either has a default address that is outside the address range (1-254 usually) or it does not have one assigned to the embedded software and accepts DHCP addressing

thank you very much for your answer but the problem still does not fix and I can not see my antiminer l3 + in the list of devices ip address
I tried to apply what you told me

antminer works well at the beginning with DHCP but when i stupidly change the antiminer configuration to static i can not manipulate the miner interface
look at the picture