Urgent help needed with a transaction

Hello all and thank you for having me.
I have a question about a transaction I made. I installed a wallet and it went fine. While it was starting the block chain download it showed me “My address” so needing to get the transfer started I went and sent the coins to it. Fast forward to today and the wallet software is still not working and will not complete a chain so I can get my coins. The wallet is beta and no support etc…bla…bla…bla.

I have the seed it gave me to generate the wallet and I have all the sending info as well. The wallet where I sent it from, BTC Wallet online is no help.

Is there a way I can get the coins back because I have the seed and the coins will not be accepted since the wallet is not there I guess. Thank you so much for reading.

This sounds do-able.

What type of beta wallet software are you using?

It is called Agama https://supernet.org/en It is all java so I thought I would try it on win 7 instead of win 10 and it does the same thing. I have done the driver patch and other few things the sire suggests but to no avail.

Ok I took a cursory glance at the API docs, specifically this:

http://docs.supernet.org/#method-dumpprivkey

If the wallet itself has issues, isn’t syncing, etc - all that will need to be done really is just to get the private key for the address that you initially sent the coins to.

If you can get the private key, you’re ready to rock and roll.

I have the wallet seed and the addy i sent the coins to. I went into the app and it wont generate a private key for the seed untill the chain is complete and the coin activated…there is a pubkey an md160 key, a btcpupkey and an NXT. I have no idea what to do from here.

I was reading the wiki and it said you can do it with a blockchain wallet. I made an account and went to import and it asks for private key…i have the seed. How can I get the private key from my seed?

This is kind of a strange behavior, it absolutely should be able to dump the private key regardless of the blockchain download. I mean, after all, it generated an address for you to send coins to, correct? Therefor we’d reasonably assume the private key must be there as well. Very interesting.

A few things you can try, is to continue to see if you can coerce it into giving you the private key. Alternatively, you could look for error logs to see why the chain isn’t downloading. Maybe that’s something that can be corrected.

One more thing that is worth a try: install the software on a different device and restore using the wallet seed.

Thank you very much. I have tried it on a win 7 box and it has the same issue. I was able to import the adress into the blockchain wallet and it shows my coins are there…but it asks for the private key and I only have the seed! :frowning:

I will keep at it but at least it seems they are still working on the project so I might just have to wait for the updated version. Thanks again and I will post progress.

No problem at all.

For what it’s worth, generally speaking the wallet seed translates directly into your keys.

If it was a significant amount of coin, and they can’t get it resolved in a reasonable amount of time, let me know and I’ll download the source and “make” it produce the private key for you.

:v:

LOL Nice! It was 14 dollars when I did it but now its worth almost 18 lol…not a lot but it is fairly substantial to me. Thanks :slight_smile: :v:

Heck yeah 14 bucks!

I’d do it if it was fifty cents. If you read back through my posts, I have a habit of reuniting people with their coins. I just sort of made that my thing somehow lol…

Dude I knew I had found the right place just by reading the topics. Nice to see people willing to help out. Take your thing and fly!!! :airplane:

Bash crypto trolls :punch:

Help crypto users :muscle:

Because - why not!? :sunglasses:

I do a fair amount of flying high, but not in a plane. rofl…

24/7 here in Oregon :cool: I did get a reply from one of the support peeps and he asked a few ???s but I haven’t heard anything back. All we need is their algorithm that created the key in the first place. I tried their option to import the wif keys but it fails hard. Still cant seem to be able to get the silly block chain to download. I tried their “add peers” function and it …well you know what it did. :poop:

/

Good good, yeah it definitely doesn’t hurt to tinker a little or throw a :hammer: at it.

Tomorrow I’ll slap together a virtual machine and download this :poop: wallet, good chance I’ll make it an offer it can’t refuse :grin:

I’m going to see if I can get as far as making a seed, restoring from a seed, and then later smashing it with a sledgehammer to get the private keys. :joy:

1 Like

Update. I got Agama to work.

I created a Ubuntu 16.04LTS virtual machine (just using regular old VMware, and download the regular 16.04LTS desktop ISO)

Next, downloaded Agama, that is some interesting stuff.

I activated Litecoin of course, keyed in the wallet seed, and viola it began to sync. All 3 bars (Bundles, utxo, Balances).

Best case scenario: You should be able to do the same. Are you familiar with virtual machines and Linux?

Next best case scenario: I could plug in your seed, let it sync, and send your coin to a wallet that is a bet more developed/easier to use than this beast. I mean it’s cool and all, but definitely needs polishing. :beer:

Cool! Never used vmware but i was an a com basic programmer at Dell. lol Easier for me to send you seed. I did get a nasty java script error and i will attach a screen shot. It says something about nodes and such.

We might as well try the vmware thing…if nothing else i will get a lesson! :woot:

It’s all good, yeah vmware is good stuff. OK so you want to first install VMware player:
https://www.vmware.com/go/downloadplayer

Next, grab the Ubuntu 16.04(.02)LTS .iso here (this is just the installer image)
https://www.ubuntu.com/download/desktop

Fire up vmware player, and create a new VM. Choose Linux OS. Maybe give it 100GB of disk space, 2GB RAM, select “Network” and choose “Bridged” for the network connection. Select “CD/DVD” and choose “Use ISO Image” and choose the .iso file downloaded above.

This should be good enough for the VM, go ahead and then “Play virtual machine” - this will kick off the installer. “Install Ubuntu” -> choose a username, location, etc… the install shouldn’t take more than about 15 minutes.

Next, it’ll ask you to reboot the VM. Then login, open up firefox, download Agama. Note: You can download Agama as a regular user, but you’ll need to install it as root. From a terminal (top left button on the desktop, search for: terminal), switch user to root using this command:
sudo su -
(Then key in the password for your user)
As root, change directory to /home/yourusername/Downloads
Go ahead and run the Agama installer downloaded above.

When this completes, “exit” the terminal (we don’t need to be root any more)

You can then run Agama as your user and you should get the same result as me, no JavaScript error explosion. :+1:

1 Like

Er yeah, you can PM me the seed too if you don’t want to mess with this crazy VM stuff. Bunch of technical brooha, probably makes more sense after a blunt lol

Ok I have 2 or 3 hours so i will load up some Gorilla glue :wink: and give it a shot…I am guessing I get the player for win but I am going to install linux on it?