Transfer a Wallet from 0.8.62 to a newer Version doesnt Work. Noob need help


I hope you can help me. I’m afraid I’ve manoeuvred myself into a technical dead end.

In 2013 I made myself a few Litcoins. I then pushed it onto a wallet which runs on a machine with Ubuntu. I put the Linux on for security reasons especially for this wallet, although I am not a professional. It all went so far and the Litecoins were displayed in my wallet.

Now I would like to put these litcoins on a current Wallet, but I can’t get it right. The wallet software is beta.

I have transferred some coins to Litebit for testing (on 09.02.2018), but these transactions are still pending and will not be evaluated. If I load the Wallet. dat on a current Litecoin core 14.2 Wallet on Windows 10, the transactions will be shown to me, but I don’t see any more coins in my Wallet. They’re all gone. Under Linux in the old software they are displayed correctly.

A “rescan” on the Windows machine has unfortunately not been successful. I had read about it in another forum.

What can I do now? Is there an easy way to transfer the wallet? The old software says “Urgent: key compromissed, upgrade required.” And my coins became victims of a hack.

Do I have to transfer the wallet under Linux? I tried to install a new wallet software (14.2) on Ubuntu, but I don’t succeed. I can’t find a manual that I understand. I wonder how I got it right back then.

Why is a transfer to the Windowswallet not enough? Do I have to prepare the Walletfile beforehand to make it work? If I have to do it under Linux, does anyone know a simple step-by-step guide to installing the current wallet software under Ubuntu?

Greets anarki

do you have any unconfirmed transactions on the new version???

Yes. All are unconfirmed and there are 0 coins. I just copied the wallet.dat into the destination folder. The transactions are shown but as not transferred

do you have the old wallet installed yet?

Yes I still have it installed on the Linux machine. There you can see the transactions, which are also not succeed. But the coins are there.

what you need to do is dump the private keys on the old wallet for every address that have coins.

them, import those keys on the new wallet.

good luck!

Thanks for the tip with the private keys. I read the private keys in the old wallet on Linux. That worked well! For security reasons, I have now encrypted the wallet and moved it to the Litecoin folder on Windows and replaced the old wallet.dat. When I start Litecoin Core, I get the error message that the Wallet. dat is corrupted. Is this related to the previous encryption of the wallet? Would it be better if I hadn’t?

Can I undo this again. In the old wallet, it only allows me to change the passphrase, but I can’t remove it completely.

hi. Thanks again for your support. In the meantime I pushed the coins with the private keys into an Electrum Wallet. There is an import function and only the private keys are needed. It all worked out. Thanks for the tip, it got me on the right track.

good to know! cheers!

all you should have to do is just install the newest version of core wallet and open it…
you do not need to send coins anywhere to upgrade a wallet…
you do not need to dump your private keys either to upgrade unless the newest version is not compatible with your older binary data…(wallet.dat file)
where are your coins now? do you have them in a electrum wallet or a core wallet?
all you need is your core wallet backup…
install the newest version and in the appdata folder…replace the wallet.dat file with your backup and rename it wallet.dat…then start core wallet and let it sync…