LTC lost in Electrum LTC wallet?

Hello everybody,

So, I was sweeping private keys into Electrum and on the first one I swept, I got the successful transaction pop up, but I didn’t click “Broadcast” as needed to add them to my wallet, I just clicked the close up button, because I thought I already had them in the wallet and broadcast was used to send them to another wallet/exchange. When I closed the window and realised I didn’t have them there, I tried doing the same again, but I never got the Sweep button as a viable option, it was just grey and I couldn’t click it. So, I tried sweeping it in WIF through Coinomi. But this didn’t work either, because when I went to and clicked on wallet details in order to get my private key in WIF, the key was never shown. I just got an empty form and where my keys in different formats had to be, there was just empty white space.

Could anybody please help me find a solution to my problem, because for the past 2 days I have been trying to sweep them with no success. Thank you a lot and have a great day!

you can sweep any private key to a core wallet by opening coinsole and typing importprivkey…stay away form 3rd party servers like electrum and run your own…litecoin only needs 25 gb of space max so just store the blockchain on a usb flashdrive…I can help with that if needed
core software is the only one wallets no one has had problems like this with…and all core wallets can be recovered as long as you back them up…cant do that with seed wallets if the server hosting the seed goes down…your coins go with it unless you have a private key…not a seeded phrase

Ok, I will try to do that with Litecoin Core as well. Thank you.

I got the message:

Invalid private key encoding (code -5)

I have never encoded my keys in any way, I simply put them as they were on my wallet. Any thoughts?

make sure you are only typing the mixed letters and numbers for the private key and not including $bitcoin$ in the front or quotes in the front or at the end…if you did not own the private key the error code would say that the wallet does not contain the key…so you just have a formatting issue…wallets like electrum and mycelium are HD wallets which are formatted differently…might try converting it to hex code if you cant get the formatting right by excluding characters…maybe this will help

looks like you need to use base58 format to import a key…I would think that core would give base58 as the output type when the key is dumped using console…not too sure about that though

I know I took a private key that I dumped using my core wallet and swept it by using any old qr code generator and typing the key and creating the code then used the phone wallet to sweep a paper wallet which worked fine…

I used only the private key, with no quotes or special signs. I think my coins are halfway into the electrum wallet, so to speak. How do you propose I try taking them out? Converting the private key to base58 or whatever base electrum converts them to, in order to find the private key?

I tried converting my paper wallet private key to a WIF format using, but where there would have been converted keys, I only saw blank space. As if my key was invalid.

I hope your not using a 12 word phrase as a private key and using 52 character string which is base 58…but anyway I am dealing with this same thing with my copay bitcoin wallet…you should have an option to export the wallet with CSV format or something like that…then you can importwallet from file in console
if your importing from mycelium to core then this method should work however see this too:

I’m using the most standard private key there is - generated through 52 character string with absolutely no modifications. I will read the article soon and see what I could do about my problem, thank you.

If you have any more advices, please share them with me.

as long as there is a value greater than zero in the address that the private key belongs to any key manager such as core wallets or 3rd party like electrum…and they will show up as not able to find if there is no coins in the address so you cant import a key that has no value attached to it basically…double check there are coins in the public address at and the corresponding private key should work every time only if there are coins in that wallet/address…hope u get it all worked out…good luck

I have coins in that wallet, I triple checked it. The thing is, no wallet recognizes my private key as valid. I suspect when I tried to sweep it into electrum and never broadcasted it, the key got transformed into some other base in electrum, but never imported there, so I could access my funds only if I was to convert this key to whatever electrum converted it. Idk how to do it, though.

you need to convert your private key to WIF format…
notice what it says about BIP38 keys…basically you need the hash of your private key and your passphrase together…I am looking at this today and will see what I can do about putting together a “how to convert”…you can check the integrity of your private key integrity at under wallet details too