Lost LTC - Old wallet, same laptop

Hello everyone,

I appreciate this may of been asked before but I need some help/advice regarding the recovery of 25 LTC from an old Litecoin-QT wallet.

Back in December 2013, I had the Litecoin-QT application on my MacBook Pro with 25 LTC in the wallet.

Years later, once realising LTC had increased in value, I noticed the Litecoin-QT application had vanished from my MacBook (I have used the same MacBook all this time). I cannot remember, nor had any need to delete the application due to having coins in the wallet.

I then tried to download the application again hoping to recover my previous LTC balance. I understand it is not as simple as this, but I am just wondering if it is possible to ever recover these lost coins?

I don’t remember ever backing the wallet up, but the laptop is the same.

Did you let the blockchain finish syncing?

If you did not then let it finish and you r coins should be there also you need to make sure that you have the latest version installed which is version 0.14.2 on litecoin.org
But only if the Application Data Folder containing the wallet.dat file was not deleted…this is separate form uninstalling and installing the application itself…you can delete litecoin and then re-download it and your coins will still be there as long as you are using the same wallet.dat file…which is also what is saved when you back up your wallet…

Thanks for the reply.

The blockchain has updated but still no coins, and I also have version 0.14.2

Is there a way to recover the wallet.dat file from my previous wallet?

if you made a backup yes…

If you have a backup you would place it in this folder replacing the wallet.dat file that is blank with your backup and then rename it wallet.dat

if no backup make sure there is only one copy of the wallet.dat file
go to your application data folder locate4d here: ~/Library/Application Support/Litecoin/

and makesure there is only one copy of the file named wallet.dat

if there are two…do not delete them…copy and paste one to the desktop and reopen litecoin with only one in the folder…if no coins then switch the wallet.dat file with the one you just put on your desktop…

one last option if there is only one wallet.dat file and you KNOW for a 100% fact that you did NOT format the drive or that you did NOT delete the wallet.dat file which contained your coins keys (backup or old wallet.dat file)…
is you can use pythonwallet and have it attempt to extract your keys from the device…

either way…you have to find the wallet.dat file…
that has your private/public key pairs in it…no matter what…this is the only way to restore a wallet unless you write down or print out private keys and store them somewhere…

Thanks for the info.

I have only 1 wallet.dat file in the folder so how can I go about using pythonwallet?

there is one more thing you need to check before trying to search devices for lost keys…

1- open your wallet and Click “file” then “receiving Address”
then right click the address that comes up and put it into blockcypher (link below)…your coins should show on that site if they are in the wallet and just not showing because the Segregated Witness has not been added to your wallet to verify the redemption of the coins…

first if you happen to know the public address already that u sent the coins to…that helps a lot by going here:
blockcypher.com and Clicking the “Block Explorer” box at the top…then select Litecoin blockchain and paste your address in there…
all history of every address can be viewed on a block explorer…
once you know the address the coins belong to then that ensures 2 things…

if you see the coins on block cypher and not in your wallet then you need to “add a witness” for the transaction by converting the private key, importing it and then “adding the witness”

if you only see one address and there are no coins in it…then you are going to have to look for an old file that has been renamed or replaced using pywallet…after installing version 2.7 of python or newer…I recommend just staying with version 2.7 as it seems to be the most universal in my experience…but other may know something I don’t…
here is the link for pywallet…you can start it after installing python by opening a terminal and navigating to the containing folder…then the command is: python pywallet.py --help for a list of all option available…you should see an option for -recov_device=DEVICE and -recov_size=FILE SIZE (number of bytes to read)
try just:
python pywallet.py --recov_device=C:/

is there a way on MAC’s to search the entire drive for all files that have a “.dat” extension?
because if you made a backup and named it something other than wallet.dat then this is the file you need to copy and paste in the appdata folder in place of the blank wallet.dat, then rename the backup wallet.dat

I really appreciate your help but unfortunately this is going way over my head. I have never used Terminal before so I can only apologise for my ignorance.

I have searched the Litecoin address on blockcypher.com and the wallet is empty.

I believe I have installed pywallet - for Mac i was taken via MacPorts?

I am unable to figure out how to rectify my problem via pywallet, again, this kind of thing is going way over my head, as I don’t have any idea how to correctly use commands via Terminal.

I know this old wallet.dat file should be somewhere on my Mac as I have never deleted anything. I tried searching via Spotlight but no joy.

I am hoping somewhere the old wallet can be retrieved with over £1000 of LTC. I am more than prepared to reward anyone who can retrieve these for me.

if you downloaded a fresh wallet it will have a different address than the one you had the coins in…make sure you are typing in the address you KNOW the coins were sent to that you are trying to retrieve them with…if the address in that wallet is empty with NO Previous Transaction History…then it is not the one your coins were in…

if you checked the address you know the coins are in on a block explorer and there is not balance in the wallet then the coins have been spent and there is no way to “Unspend” a Spent transaction once it is confirmed on the blockchain…sorry but you must have spent your coins and don’t remember if the balance of the address says zero…

in the block explorer at blockcypher you can scroll down and see the address you sent the coins to… it will show the address you typed (the address you know the coins are in) in on the left and the address you sent to on the right along with another smaller transaction which is the miner fee paid to have the transaction confirmed on the blockchain

OK I have managed to locate the correct Litecoin wallet, by going through my transaction history on bitbargain.co.uk (where I originally purchased the Litecoins from).

I have entered this wallet address into blockcypher.com and it is showing my correct LTC balance of the wallet I am trying to recover. So I now know my LTC are still there I just need to find a way to convert these into my Litcoin-Qt wallet?

Any update or advice regarding the above?

you can only import into other wallets by importing private keys or sending to address by creating a transaction so if you have the private key for the address that the coins are currently in then you can put them where ever you want…

if that address is in a core wallet that you are in possession of then you can obtain the private key but if it is in an online wallet and that online wallet does not allow you to have your private key then there is nothing that can be done…

Thanks for all your help and advice, much appreciated.

I have now learnt the only way this can be resolved in by recovering the lost wallet.dat file?

Would it be worth taking my laptop to a data recovery expert and see what they can do?

it all depends on the cost to reward ratio but yes…you can recover old keys like that using pywallet from essential any device that had keys on it…
as long as the drive wasn’t formatted or something like that…if you formatted the drive forensics would be the only way to recover it then…and doubtful if there were too many overwrites…

I feel I need to revisit this now the LTC price has increased.

Can someone please explain to me (in simple terms) how to use pywallet on Mac?

I have summarised my issue below, and understand using pywallet could be my last chance to recover lost coins.

Back in 2013/2014, on the same Macbook Pro I use today (SSD hard drive), I had 25 Litecoins in my Litecoin-QT application.

The wallet was not encrypted and my hard drive was never deleted or re-formatted.

For some reason or another, the years went by and I forgot about the Litecoin-QT application (mainly because the LTC value had not increased).

_Then one day, I realised the Litecoin-QT application was missing from my Mac, I had never intentionally deleted anything, but I think maybe the application went missing with a software update. _

I have since tried to reinstall the Litecoin-QT software and synced with the blockchain - no coins showing!

I have the Litecoin address where the coins are in and I have confirmed it has a balance of 25LTC.

I have heard alot about using pywallet to try and recover the lost wallet.dat file or the private keys for it, and really need to know how to use this option in order to try and recover my coins.

Did you figure it out already?

It can be easy to recover sometimes bit sometimes it’s not that trivial. If you’re missing files it might even be impossible…

If you need help I could assist you…

Hi, no never figured it out, I gave up tbh :thinking:

You did never re-install the laptop, right?
If that didn’t happen there’s still a chance the LTC’s can be recovered.

so, this is still unsolved? @marmiteman

I have same problem same Mac but it’s been lying unused since 2014 with no software updates and never online since 2014, but I also have about 25 coins in a Litecoin wallet on the desktop.