Litecoin sync issues (1 LTC reward for help)

Dear Community,
I just downloaded the litecoin application to store my coins offline. I generated a address to receive my coins but it did not generate a private key for this (stupidly). The litecoin sync has crashed at least 10 times on sync with a error bad data block error.

I have restarted it in -salvagewallet mode, rescan mode, reindex mode and it never finishes.

If I look up the transaction i can see that my litecoins have not been redeemed. What is the best approach to make sure that I get my coins? Do I just need to wait until it finally syncs and see if they appear in the wallet. Odd thing is in my receive transaction window I dont see the original receiving address.

Any ideas/pointers? Willing to send 1 LTC if someone helps me find a solution.



  • what application did you download,
  • from where did you download it?

Can you post the address you send your coins to? or the transaction ID.

I downloaded the application litecoin core from (using https:). After some research I can see that the transaction is not redeemed (checked this on

Main issue I have at the moment is that the sync keeps failing. Each time I run it it does get further in processing the transactions. I am hoping that once the sync is done that the coins are redeemed and show up in my offline wallet.

Try and not make the same mistake I did. Make sure you sync the blocks first, then create a private key then send the coins offline.

Openly the software should work by processing recent transactions 1st and not blocks from 5 years ago. Makes more sense to me this way.

If you generated an address…then you generated a private key…the private keys are stored internally in your software and not on the network…you are the only one with access to them…
you need to wait until the wallet finishes syncing before you do anything at all first…and make sure you have your backup containing that address as it is now the only way to get your private key…

if you have your backup…open you appdata folder located here:
and replace the wallet.dat file with your back up and rename it wallet.dat
then restart litecoin…wait till it syncs and your wallet will be restored

to get your private key you will cliick help…debug window…console

then type
walletrpassphrase (passphrase) 1000
this will unlock your wallet for 1000 seconds…now type
dumpprivkey (followed by the address the coins belog to)
copy and paste this private key and this is your private key…
if you are not synced this will not work
please wait until you are synced and verify that the address your coins belong to is in your wallet by clicking “Receiving Address’” under the file tab
if you are not synced you will not see your coins yet and private keys are only needed to recover coins or sweep them to another device…do not give anyone your private key as your coins can be stolen using it

Thanks for the reply. I am still having problems syncing. Windows 10 running 64 bit.

I am consistently getting the message at different stages:

2017-09-21 04:33:51 ERROR: ReadBlockFromDisk: Errors in block header at CBlockDiskPos(nFile=7, nPos=2880204)
2017-09-21 04:33:51 *** Failed to read block

Any idea what this is?

Disk read error…are you sure you have at least 25 gb of free space for the blockchain?
Once you are sure your backup is in place and you renamed it wallet.dat and there is only ONE copy of wallet.dat in the AppData Folder…
try starting litecoin from command prompt…
right click the shortcut if you made one on your desktop and click open File Location…then at the address bar at the top right click and click "Copy Address as Text"
now click Find/Cortana and type cmd
once command prompt opens type:
cd (then right click in the window to paste litecoin’s location you just copied to the clipboard)
now type:
litecoin-qt.exe -reindex -rescan
this will resync the block headers and then sync the chain…assuming you have enough disk space available and no memory issues…
you can always run a "Memory Diagnostics in windows"
click start…programs…Windows Administrative Tools…Memory Diagnostics…just to be sure

I have plenty memory and space. 100GB free and 16GB Ram. I will do the memory check like you mentioned and see if something is wrong and then try the steps above :slight_smile:

you just need to reindex then and then rescan…reindexing will get you all your headers again which is what it is having trouble reading I am pretty sure

do it just like this from command prompt:
litecoin-qt.exe -reindex -rescan

in that exact order…it wont rescan unless it is indexed properly…

also salavagewallet is something completely different too and you only need to do that if the application says your wallet.dat is corrupt…

1 Like

if it still wont finish then uninstall litecoin and delete your appdata/roaming/litecoin folder…MAKE SURE YOU HAVE YOUR BACKUP SAVED SEPARATE

then reinstall litecoin and run it…making sure there are no transactions in the wallet and it starts to sync…then close litcoin with file tab…exit

then open your appdata/roaming/litecoin folder and replace the wallet.dat file with your backup and rename it wallet.dat…deleting the first wallet.dat so there is only one copy which is your backup…then restart litecoin and it will resync properly because there are no headers yet

hey man,
I found out what the issue was. My hard disk was encrypted and this is why I was getting this disk error. I moved it to another machine and copied the wallet across did the re-scan and it worked 1st time. I think one improvement to the software would be to give a warning message on uninstall to take a backup of your digital wallet.dat file. If you have a litecoin address send it to me as your info was helpful.

thanks - thread closed :wink:

I’ve got the same problem
Send my litecoin from Bittrex to my LoafWallet and it on not yet redeemed
Can’t get my coins

Please help me!!!

Did you check the transaction on blockchain info? Bittrex is getting hammered by traffic right now it could just be slow.