Litecoin Core on Raspberry Pi 5

I’ve been trying to install Litecoin Core on the raspberry pi 5. I first began by installing the latest aarch64 linux binaries, however litecoin-qt wouldn’t launch let alone run. I then tried to compile from source code according to the instructions on github. The dependencies all installed without trouble except Berkeley Database 4.8.30.NC which declined to build complaining that it couldn’t “guess it’s environment”. I skipped db-4.8 and continued with sqlite and qt installs without trouble. I then tried to run the aarch64 binaries again and litecoin-qt started and ran normally. The wallet and gui seem to work normally but I don’t have enough space on my microSD card to download much blockchain and do testing. Now the questions:

  1. How did litecoin-qt start and run without Berkeley db-4.8 built and installed? The installation instructions at github warn against using any later version other than db-4.8. saying later versions “break binary wallet compatibility” whatever that means. I searched both raspbian64 and Ubuntu 22.10 (tried both OS with same results) for any trace of Berkeley db and could not find any version of it anywhere.
  2. Is Berkeley db-4.8 contained within the aarch64 binaries? I must have installed whatever dependencies the litecoin aarch64 binaries needed to run?
  3. Is there any way to tell what version of Berkeley db my Litecoin Core v0.21.2.2 is using?

BDB4.8 is used by the legacy wallet system. If bdb isn’t available, Litecoin Core will build without it, but disable the wallet. If you built from v24 (which is still unstable), then there’s also the option of descriptor wallets which uses sqlite. For building BDB4.8, did you follow the instructions in docs/

It should build on a raspberry pi5 (at least it worked for me last week). I was also able to run core on my pi5 from the prebuilt binaries.

Are you absolutely sure you’re running the 64bit version of Raspberry Pi OS?
If you’re using the same SD card that was previously used in a Pi4 and did a OS upgrade for the Pi5, you are not running in 64-bit! I was having issues until I reinstalled the OS.

Is there any way to tell what version of Berkeley db my Litecoin Core v0.21.2.2 is using?

Only v4.8 is supported. The ./configure step should show which version you have if I remember correctly.

1 Like

Thanks for your reply. I attempted to build the c++ version of BDB4.8 with ../dist/configure --enable-cxx. The build fails immediately and the error log left in build_unix concludes with “configure: error: cannot guess build type; you must specify one.” The build script evidently uses uname to probe its environment and some of those values come back “unknown”. I poured over BDB documents for a couple days but never found a solution. I’m sure I used the 64-bit version of Raspberry Pi OS. I also tried to install litecoin core on the raspberry pi version of Ubuntu 22.10 with the same result. Come to think of it, I don’t think I tried just to run the binaries only on Ubuntu 22.10. I may have started immediately with dependency installations and those stalled at BDB4.8 with the same error log as raspbian 64.

In any case, the only anomaly I see with litecoin core is that on first start I was given the option to create a wallet and there were other choices which included importing a wallet. I’ve never seen that screen on my linux desktop versions. I chose to create a new wallet and that completed successfully. The wallet seems all there with all the menu choices. It will be some time before I can test it because I don’t have storage enough to load the blockchain. I’ll try to determine what version of BDB the wallet is using.

Here’s some further info in case someone else runs into this problem: I went back to my Raspberry Pi OS 64-bit microSD card. I had installed dependencies according to the instructions on the litecoin github page up to BDB4.8 where I got stuck then gave up. This time I tried to run the aarch64 binaries and litecoin-qt started and ran but with no wallet. I then installed the sqlite and qt dependencies. After these, litecoin-qt starts and runs normally with wallet (and without messing with Berkeley DB4.8 at all). I found an easy way to view which version Berkeley DB litecoin-qt is running with the gui: In the wallet under Window/Console/Information tab/ General Information heading it show the Berkeley DB version. It’s 4.8.30. despite me not installing it. So good. I’m really glad to get this running finally!