Lite coin balance not reflecting on trust wallet.. any ideas of why?

I have sent Litecoin from my binance account to my trust wallet Litecoin address (same address I always use!) this time, the coins “didnt arrive”.

I checked on the chain, the coins are there in the address, credited. however, the balance doesnt show up at trustwallet.

any idea of why and how I can solve this.



Do you have the passfrase of the wallet you have?
Check if they are identical with the trustwallet you are using now.

Yep. Everything is identical. It’s the same wallet I use all the time.

For some wierd reason this time the ltc is not there, hopefully, least of the problems because it’s on the chain. I just don’t understand why it’s not displaying on the trustwallet.

What should I try to do ?

Explore trustwallet private keys and try to add to a different software wallet ?

Run a litecoin core and try to extract the coins manually from there ?

Suggestions ? Anyone with similar problems ?

Btw: I tried installing trustwallet on different phones and machines, imported my current wallet to it, and nothing. Just nothing shows up. I guess it’s a trustwallet issue.

just solved my issue by :

  1. downloading electrum Litecoin, available at the OFFICIAL Litecoin website (watch out for scams) always download from Litecoin official website.

  2. decoded my trustwallet 12-words seed phrase using Ian Coleman tool.

  3. imported into electrum Litecoin… worked!

in the mean time, trustwallet still not reflecting my chain balance. go figure. what a POS wallet.