Issue with restoring wallet from backup file

Hello, i have an issue with restoring my wallet from backup file.
I use a newest client v0.18.1
After i replaced default file “wallet.dat” on my backup file, i opened a wallet and got a meassage “failed to rescan thw wallet during initizlization”.
I tried another option, to open backup from client and got a message “Wallet loading failed”

Could you advice how to solve this problem?
Maybe there is another way to restore a wallet?

2021-05-04_202143

First of all, turn off litecoin core and do a backup of the backup and any wallet you have currently.
Then start again and open debug.log and try to see if you get more information from that.

I reinstalled wallet and reindex blockchain, now when i try to open wallet i get a message “last wallet synchronization goes beyond pruned data”
2021-05-06_200611

During synchronization litecoin app crashed repeatedly or my pc switched off.

What kind of messages i should find in dump?

You did not synchronize in a long while, the data your wallet needs is already pruned.
You can redownload the whole blockchain … or migrate to a wallet that doesn’t need it.