Iimport Private Key

Hi, new to this,

Im trying to import a private key

when I try i get the following message…

21:03:03 importprivkey(…)

21:03:03 Error: Please enter the wallet passphrase with walletpassphrase first. (code -13)

Does anyone know what i need to do to sort this Error code 13 ?



I don’t know what kind wallet you are using, but looks like you are enter a encrypted private key, so you need the passphrase. I hope you remember the passphrase.

Thx for reply.

So I bought Litecoin way back and it looks like I have stored them in block cypher - and I have the Litecoin address and private key.

So today I have set up a Litecoin core wallet with the aim to import the private key into this wallet. I have a pass phrase for this wallet

here is is how it is done on a paper wallet…it is for BTC but works the same for Litecoin Core Wallet.


On Litecoin Wallet QT

open the following


Open Debug Window

Then go to menu: /Help/Debug Window


Unlock your wallet

If your wallet is encrypted (I hope it is!) you must unlock it. If not just skip this step.

To do this just type into the box at the bottom:

walletpassphrase “YourLongPassphrase” 600

Note: The 600 means your wallet is unlocked for 10 minutes (600 seconds).


Run Import Command in Debug Window

In the console at the very bottom is a text entry box. In here enter:

importprivkey yourPrivateKeyInWalletImportFormat “TheLabelThatIWant”


You now have to be patient. On a fast PC it takes 2 minutes to import, and during this time it looks like you application has hung. After waiting a few minutes you will see:

p.s. it ‘always’ takes longer than 2 min stated above IMHO…just leave it alone and wait :slight_smile:

Anyway …I have this Zeroxed along with my paper wallets something like above for reference you
swipe all funds out and then send/do whatever you need to do in the wallet. I then send any ‘change’
to a NEW paper wallet and file that back in the safety deposit box rinse/wash/repeat



Perfect Brad. That has worked and I now have the coins showing in my wallet.

In step 2 I wasn’t aware of having to add 600 after walletphrase to allow me a time window.

All good and many thanks.



awesome! glad to see you recovered the coins. always good to know that coins were rescued vs being lost forever.

1 Like

Glad it worked out. (why can this never be for Bill Gates or a Mega-Whale!) :slight_smile:

HODL’ing is hard at these LTC/BTC prices. :slight_smile: