I would appreciate some Help with Litecoin wallet

Hi. My buddy, who is Not very Tech savvy, called me, in a panic, (as He considers Me his Tech Guru… And I am no Guru, lol)… Anyways… He had a Litecoin wallet from approx 2013, on his laptop, (Windows 8) His litecoin wallet got synced, He says, and He tried to send 1 ltc to Bittrex, and it stayed “Pending” for over 12 hours, did not complete. His wallet had some message about needing an upgrade, so he downloaded a new wallet from Litecoin.org, installs it, says that he did not uninstall anything, just let the new wallet do it’s thing… Now his wallet is showing a Zero Balance. I think he said he had 50 or 60 ltc in old wallet. I don’t know if he had a backup, (I doubt he did, but I haven’t gone and looked around his laptop to try and find anything yet)… My “Non-Guru” thoughts are… The data with coins, wallet.dat, or something, Must be on his laptop… Somewhere!!! … Am I right? Or has he lost his coins? He’s in a panic, and I hope to help him this weekend. Could someone please give me some help/guidance? Any help is appreciated.

Thanks in Advance! :slight_smile:

you need to download the latest version of litecoin at litecoin.org …everything will work fine once you install the newest version…

1 Like

you do not need to worry about the Application Data for litecoin at this point…you just need to download the latest version (0.14.2)and the wallet will use the data from the old wallet

but if you do need to restore your wallet…find the Appdata folder at c:/users/(current user)/Roaming/Litecoin and place your backup here…as you asked… replace the wallet.dat file with the backup and rename it wallet.dat…

this is assuming you deleted the Litecoin application data folder or there is not one there…

you will also need to open folder options and click the box for “view hidden items” in order to see the Appdata folder

again you only need to worry about this if you changed something…you should just be able to just download, sync and go

1 Like

I am not sure if he had a backup, or not. He insists that he did not uninstall anything, and I am certain that he wouldn’t know how to uninstall anyways. He said the old wallet showed his balance, then he installed new wallet, and when it was up and running, and synced, there was a zero balance.

if the new version is showing a zero balance then there are two copies of wallet.dat in the appdata folder or the backup was not renamed wallet.dat while deleting the wallet.dat that the wallet made when it was installed…

ensure that there is only one copy…the backup containing the coins …and that it is named wallet.dat

1 Like

Thank you so much for the help. I appreciate your time! I will try and get it fixed for him tomorrow! :slight_smile:

So… I’m looking at the computer right now, and there is only 1 wallet.dat file, and it is dated 2017-10-21 which is when he installed new Litecoin wallet. The only 2 files from 2013 is a text document (which is empty) called db, and the 2nd is a “.lock” file.

I checked the 2013 wallet address, in explorer.litecoin.net, and the coins are still there 88.9 balance. But new wallet has different addy. It shows old transactions on wallet, but zero balance.

ok…that “2013” file…that is the backup
place that in the app data folder

now delete the wallet.dat file…
now rename that 2013 file …wallet.dat and restart litecoin-qt

Is that the .lock file, that i need to rename wallet.dat? To replace the wallet.dat that I’m going to delete?

lets start over…

open the older version wallet (the one you can see your coins in) and click file…backup wallet…now save that file one oyur desktop or somewhere…now repeat my previous post…
and open the new version of litecoin…which will use the same appdata folder to show you your coins

do not do anything to any file except for the wallet.dat file in the appdata folder

The Old wallet is gone. I assume when the new wallet installed, it vanished, and the new wallet has a different address than the old wallet had.

I can not find a backup file anywhere.

In the appdata/roaming/litecoin file I can see 2 files from 2013. 1 is an empty text file named db, the other is a .lock file. All other files are dated Oct 20 2017, which is when the new wallet was installed.But there is only 1 wallet.dat file, whether wallet is running, or off.

If i go onto explorer.litecoin.net, and check the original wallet’s address, it shows the Litecoin balance as 88.9 coins, which is correct.

On the new wallet, it shows (on overview page), old transactions from 2013/14 era, and shows the transaction where the LTC was transferred to the old wallet, But, the wallet has a new address than the old wallet, and is showing a zero balance.

As it stands right now, nothing has been deleted from the laptop, by myself, or buddy who owns the laptop. If anything was deleted, it was from when new walled installed itself.

Sorry if I didn’t explain it right before, I am only partial computer literate. :dizzy_face:

I didn’t look for the old wallet, as I assumed it would’ve been overwritten by new wallet’s install.

the old wallet is not gone if you did not delete the appdata folder…you may need to uninstall the newest version in order for the older version to work…may need to reinstall older version as well…
then once you have the information…reinstall newest version and import your wallet.dat file

Thank you again. I will be going to my buddy’s place tomorrow, to try and get it working again. I appreciate your help! :smiley:

Well… I got the old wallet running, synced, and made a back up. I started the new version qt wallet, copied the old backup into the AppData/Roaming/Litecoin folder and deleted the other wallet.dat folder. Still no balance or pending balance in wallet. It showed 87.9 LTC in old wallet, when I made the backup. … It does show the transactions, including the 87.9 ltc that got sent to the wallet on 2/10/2014, and shows as confirmed. It shows 3 sample tranactions, all unconfirmed, and all from this month, and this year. I dont understand why this won’t work. He wants to get the LTC out of the wallet, and onto a trading site, like Bittrex… But obviously , he can’t access it. Tonight, I shut down the Litecoin client on his laptop, emailed his backup.dat to myself, and installed it on my desktop pc… Same thing happening at my place too, shows transactions, but no balance. It is showing the proper LTC address too. I checked the address on Litecoin explorer, and it shows the coins there… I have tried this numerous times, as well… Fired up the old client, let it fully sync, Backup, shut it down, fire up new client, copied and renamed, to wallet.dat, and replaced it in the appdata folder, after it synced up, and before it synced up, and each time there is no balance. and the old wallet shoes error… Upgrade needed… Thus the 3 unconfirmed sample transactions. Do you have any suggestions, on what can be done, to recover these coins?

Thanks again.

Update… I cancelled the 3 unconfirmed Transactions, and BOOM… The balance showed up! Thanks for the help!

Yes, usually starting the new client with -rescan argument once only, sorts that out to. It rescans the blockchain to rebuild transactions in the wallet file to sort stuff like that out. See, you are his tech guru!

I think helping him is really worth you getting half of his litecoin. Good luck pitching that to him…

Lol… That’s a great idea! I will pitch that to him! Hahaha!!

Thanks for your help too Trix!!:smiley:

yes…now download the newest version of litecoin and run it…coins should pop up now that you have the old wallet working and synced…DO NOT DELETE THE APPDATA FOLDER THOUGH…just simply install version 0.14.2 while you still have the old one in place and it will use the same information to sync with…but it will rescan and pick up your most recent transactions

1 Like