How do I connect to my node using LiteWallet?

Hi there!

I just opened a litecoind node on a VPS now. Port 9333 is fully open and the chain is fully synced (I’m checking with ./litecoin-cli --getinfo)

However, on LiteWallet, for some reason I can’t connect to my node at all. I started the node with “./litecoind --externalip=185.196.21.128 --bind=185.196.21.128”

In theory, using 185.196.21.128:9333 should allow me to use my node right? Why I can’t use it even if I can see inbound connections?

Thanks!

2 Likes

You should know that!

I believe this functionality is currently not longer working. It’d be best to contact the litewallet team for more info: support.litewallet.io.

1 Like

Thanks!

Hello. In order to connect Litewallet to your node you must add the whitebind or whitelist options. Use [host]:port notation for IPv6.
Example using whitebind
litecoind -whitebind=bloomfilter@<VPS IP>:9333
Example using whitelist
litecoind -whitelist=bloomfilter@<Litewallet device's IP>:9333

All the best :>

1 Like