Help w/ Gawminer Config using CGminer 4.3.5

I got a Gawminer "Black Widow"
I am running CGMiner 4.3.5 and I know that it CAN see it because when I run cgminer -n I get…

cgminer -n
[2017-09-15 09:38:20] USB all: found 16 devices - listing known devices
.USB dev 0: Bus 2 Device 1 ID: 0403:6001
Manufacturer: 'FTDI’
Product: ‘FT232R USB UART’
[2017-09-15 09:38:20] 1 known USB devices

BUT… I cant seem to find a cgminer mining config that sees it and will run with it.

My current config has the least amount of errors of all the confis that I have tied… this is what I have it set to:

cgminer.exe --scrypt -o stratum+tcp://ltc.give-me-coins.com:3333 -u Incert-name-here -p 1234 --no-submit-stale --scan-serial /dev/ttyUSB0 --zeus-chips 64 --zeus-clock 300 --scan-serial /dev/ttyUSB1 --zeus-chips 64 --zeus-clock 328 --zeus-nocheck-golden

and with it I get:

cgminer version 4.3.5 - Started: [2017-09-15 14:43:32]

(5s):0.000 (1m):0.000 (5m):0.000 (15m):0.000 (avg):0.000h/s
A:0 R:0 HW:0 WU:0.0/m
Connected to ltc.give-me-coins.com diff 1.02K with stratum as user Incert-name-here.1
Block: f9d1537e… Diff:753K Started: [14:43:32] Best share: 0

[U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit

[2017-09-15 14:43:31] Started cgminer 4.3.5
[2017-09-15 14:43:31] Gridseed Detect: Failed to open /dev/ttyUSB0
[2017-09-15 14:43:31] Gridseed Detect: Failed to open /dev/ttyUSB1
[2017-09-15 14:43:31] Zeus Detect: Failed to open /dev/ttyUSB0
[2017-09-15 14:43:31] Zeus Detect: Failed to open /dev/ttyUSB1
[2017-09-15 14:43:31] No devices detected!
[2017-09-15 14:43:31] Waiting for USB hotplug devices or press q to quit
[2017-09-15 14:43:31] Probing for an alive pool
[2017-09-15 14:43:31] Pool 0 difficulty changed to 1024
[2017-09-15 14:43:32] Network diff set to 753K

WTF?
BUT… BUT…CGminer -n said it could see the GAWMiner!

aka:
.USB dev 0: Bus 2 Device 1 ID: 0403:6001
Manufacturer: 'FTDI’
Product: ‘FT232R USB UART’
[2017-09-15 09:38:20] 1 known USB devices


HELP! lol lol

Any ideas?
Thanks in advance!

GAW Miner is a Zeus Chip and it has a FT232R UART to usb chip that communicates the work to your computer and converts UART to USB…its just showing you the name of the internals of the miner

try removing the -scan-serial /dev/ttyUSB0 and USB 1 and replace it with -S auto --hotplug 5 which will scan all ports and find all minable devices and your GAW miner is a hotplug item because it uses external power to you need that enabled

also you only need to specify the chip number and clock for two of the same devices one time…try this:

cgminer.exe --scrypt -o stratum+tcp://ltc.give-me-coins.com:3333 -u Incert-name-here -p 1234 --no-submit-stale -S auto --zeus-chips 64 --zeus-clock 328 --zeus-nocheck-golden

also I noticed you are using windows…zeus chips have problems communicating with windows…guarantee you run it on any version of Linux and you will have top notch results…if you do get it to connect to windows it will cut off after 30 minutes or so…windows just doesn’t like the FT232R UART to USB controllers…windows only like RS232 UART to USB controllers…anyway try the script and I’m sure it will connect but you’ll be a lot happier on Linux in the long run…maybe running your miner off a raspberry pi…that is what I do anyway for lower power consumption and they run Linux wonderfully

Thanks but unfortunately it didn’t work…

I tried the script with -S auto --hotplug 5
and as you wrote out my entire Bat file., without the hotplug5

Now you have me thinking…
I have another Miner running off of this windows rig. so I need to keep windows up (for now)

BUT… Maybe I cam run this Gawminer on Ubuntu on windows?
I’ve heard that you can run Ubuntu in a Windows…
Basically Ubuntu binaries running nativly in Windows

This will be a new interesting adventure!
Thanks for your efforts…

I never tired that…a virtual machine should work fine

also just connect the miner to the machine and make sure you see FT232 as the device under device manager…and download zadig and change the dirver to winusb…this is more than likely your issue with windows

here the link for zadig: http://zadig.akeo.ie/
don’t need zadig on Linux though

open it and then plug in the miner then a the top click view all devices…your miner should show up as ft232…select that and then select change driver to winusb…and ignore the warnings…trust me…I had the same issue with windows not recognizing my zeus at first…

you can also do a search for "windows not recognizing zeus miner or gaw miner"
this is how I figured out how to get mine to work…

  • In Windows, Open Explorer, Go to Computer > Device Manager.

  • Scroll down the list, Click on PORTS (COM & LPT)

  • There you should see: USB Serial Port (COM X) where X is Port number where Zeus is connected

  • Remove --scan-serial from bat. Insert that COM port address at the end of your BAT file, fire it up to test

  • Your “clock” @ 300 is too high to Start with. Turn it down under 300. Once you get it running w out errors, find a good speed for your GAW Miner


Sample BAT here:

cgminer.exe --scrypt -o stratum+tcp://amazingpoolmakerich.com:5555 -u USERNOOB -p 12345 --nocheck-golden --chips-count 128 --ltc-clk 312 -S //./COM8

this is for a ZEUS Thunder 6X that runs 128 chips
yours is half that so enter 64 for chip count “–chips-count 64”

in this example, ZEUS Thunder is connected to COM8

make sure you save it as filename.bat,
place that in the dir where your cgminer exe is located.
fire it up