HELP! I cant connect my computers to mine using my wallet! (Solo mine)

ltc
litecoin

#1

So currently I have Litecoin core open and running, on the same computer I have a CPU miner running just fine.
the problem is that I have 3 other laptops I want to mine with but I can’t since it won’t connect and it gives me this error (the laptops use linux/ubuntu)

./minerd --url=http://localhost:9332 --userpass=username:password --coinbase-addr= (Blablabla)

[2017-03-09 18:55:45] 2 miner threads started, using ‘scrypt’ algorithm.
[2017-03-09 18:55:45] Binding thread 1 to cpu 1
[2017-03-09 18:55:45] Binding thread 0 to cpu 0
[2017-03-09 18:56:15] HTTP request failed: Operation timed out after 30003 milliseconds with 0 out of -1 bytes received
[2017-03-09 18:56:15] json_rpc_call failed, retry after 30 seconds

On the PC with the wallet its running just fine as seen below.

C:\Users\Harrison\Desktop\New folder>minerd --url=http://localhost:9332 --userpass=username:password --coinbase-addr= (blablabla)

[2017-03-09 18:18:41] 8 miner threads started, using ‘scrypt’ algorithm.
[2017-03-09 18:18:41] Binding thread 6 to cpu 6
[2017-03-09 18:18:41] Binding thread 7 to cpu 7
[2017-03-09 18:18:41] Binding thread 2 to cpu 2
[2017-03-09 18:18:41] Binding thread 1 to cpu 1
[2017-03-09 18:18:41] Binding thread 4 to cpu 4
[2017-03-09 18:18:41] Binding thread 3 to cpu 3
[2017-03-09 18:18:41] Binding thread 5 to cpu 5
[2017-03-09 18:18:41] Binding thread 0 to cpu 0
[2017-03-09 18:18:41] Long-polling activated for http://localhost:9332

Which I like that but I need more power :slight_smile:

Sorry if this is in the wrong place, I’m not used to forums and I have only used one once before.

If any more info is needed I’ll be glad to provide it. :grin:


#2

Does this fix it?


#3

Darn, I wish I could say it did. Thanks for the reply! this is what my config file looks like;

rpcuser=username
rpcpassword=password
rpcallowip=192.168.0.0/16
rpcport=9332
daemon=1
testnet=0
server=1
gen=0
block_nTime=1317972665
block_nNonce=2084524493

So now instead of “Operation timed out” It says Connection refused, any thoughts?
Also, my computer doesn’t seem to be listening to 0.0.0.0:8332 which isn’t a good thing according to other forums.

TCP 0.0.0.0:80 LISTENING
TCP 0.0.0.0:135 LISTENING
TCP 0.0.0.0:443 LISTENING
TCP 0.0.0.0:445 LISTENING
TCP 0.0.0.0:3005 LISTENING
TCP 0.0.0.0:5357 LISTENING
TCP 0.0.0.0:5673 LISTENING
TCP 0.0.0.0:5681 LISTENING
TCP 0.0.0.0:5682 LISTENING
TCP 0.0.0.0:7680 LISTENING
TCP 0.0.0.0:7790 LISTENING
TCP 0.0.0.0:9332 LISTENING
TCP 0.0.0.0:9333 LISTENING

Maybe I shouldn’t have posted all of my listening ports but meh…


#4

On computer running core:

rpcallowip=192.168… Edit: Not sure why but when I save two wild card asterisks don’t show.

Or alternatively individual statements with the ip address of each laptop.

On each laptop:

./minerd --url=http://addressofcomputerrunningcore:9332 --userpass=username:password --coinbase-addr= (Blablabla)


#5

Doh! I didn’t even notice, for the -url= you have the IP address of the computer running core correct, like shyliar has?
The 3 Linux laptops aren’t using --url=http://localhost:9332 correct?

If you are sure they’re pointed at the PC running litecoin core, and still no luck, the next thing I am thinking is to scan the PC from one of the Linux laptops using this:

Just to confirm that you can connect to that IP and that port, from another host on your LAN.


#6

your miner is going to connect to the port that is listening …8332 for get work and usually 3333 for stratum…however make sure you are setting the network connection settings to connect to connect to peers peers to 9333 because wallet uses port 9050 by default for peer connections… 9332 and 9333 are rpc port and peer connection im pretty sure…

you could also try connecting everything through a VPN and setting proxy settings for that VPN to connect to the 127.0.0.1 and us your listening port for that connection…this should ensure that your mining software is using the same local address’


#7

You can map your network using Portable box and any linux distro image installed to it…then you will have linux running locally and can map your network with that…only recommended if your familiar with linux or are willing to learn…also in windows a simple ipconfig /all command in command prompt should show you everything that is connected to the network your computer is on…


#8

Hey, thanks for the reply!

I fixed it, and that’s where I went wrong, I didn’t have the IP of the receiving computer and on Windows Firewall for the receiving computer, I had to add a new rule which allowed ports 9332 and 8332 and then it worked just fine! thank you all for your help!