Guidelines for solo mining


I need help for solo mining, I already search at google and try some of the guide line but there’s no result of doing the right solo mining, i’m using cgminer 3.7.2 and just got error pool 0 slow/down or url or credential…
please help me…

you need to run litecoind as a server form command line using -server flag also you need to create a .conf file containing the proper information…I have only used p2poo which is similar to solo

please help me how to create proper .conf? my conf is


i’m using bfgminer with set

bfgminer --scrypt -o -u username -p mightypass --generate-to wallet addr

but always get that error “pool 0 slow/down or url or credential invalid” same with cgminer too
i’m stuck…

Change gen=0 to gen=1 this makes you generate blocks and your user name needs to be the address you are mining to…then you need to add -http-port 9333 to bfgminer

alright…i’ll try 1st, thanks bakd247

1st i run litecoin-qt -server
bfgminer --scrypt -o --http-port 9333 -u my wallet addr -p mypassword form litecoin.conf
it’s come with error “No server were found that could be used to get work from”, “please check the details from the list below of the servers you have input”

try opening your wallet and use proxy to connect to peers under network tab and see what that does…did you start litecoind first and then bfgminer in that order? might try starting like this from command prompt: litecoin.exe -server -listen and also you will need to set bfgminer to -listen i’m pretty sure

after i set network connection through proxy sock 5 there’s no connection at all from the nodes,

im doubt if there’s any posibblity of doing solo mining through litecoin core?
because i already test mining through pools the hash rate is very low…

is there updated guidline how to solo mining …?

I was wrong about that…doing that would make your litecoin node use bfgminer to send and receive work…this should work if you set bfgminer to -listen and setup a VPN though…
change that back to map using UPnP and make sure you are accepting incoming connection through your firewall…one main problem might be that you need to connect to your litecoin node externally using your external up address…otherwise you need to set up a VPN to use local intranet address’. And tell the vpn to use bfgminer as the proxy…then tell bfgminer to connect to your local host…
One more thing you probably need to add port=9332 to your .conf file…
Also double check you are using a version of bfgminer that supports solo and not pool only as the setup /run scripts differ

Make sure you are running litecoind in the background and telling bfgminer to use your address as the IP address…this is because litecoin registers your payout address with your local DNS server in your router
so one might try using the payoput address in place of the ip address when starting bfgminer
open cosole and type help…I am pretty sure you need to use the -addnode option as well as the generatetoaddress nblocks address (maxtries) option

I know dmaxl/cgminer supports solo mining external of wallets…not to sure about bfgminer though…under configuration options you should see an option to enter the bitcoin/litecoin address you are mining solo for…which is different than the -o option where you put pool info…
I know that every address generated by wallets is attached to the IP address in DNS…that’s the only way send/receive can work…so you just need to make sure you are not still trying to connect to a pool when starting bfgminer with the -o flag…and that you are connecting to the local host and mining for your solo address

I think I got it…open console and type
generatetoaddress nblocks address (maxtries)
and this will start the core default cpu miner…then you run proxy locally on the same machine and point your miners to that ip address on port 9333 for the proxy and any other port pointing the miner to the proxy…youmust use separate ports to send and receive…litecoin uses 9333 to receive so this is twhat you point the proxy to…and most pools send that work to a miner on port 3333 then you connect your miner to port 3333

or just try http-port 9333 on bfgminer once you start litecoind with generatetoaddress option

hope this makes sense…good luck