Found old wallet.dat file but wallet is encrypted


I have found an old wallet.dat file when clearing out my old HDD’s. It looks like wallet backup files from 2013-2014 with the format LTC28112013.

I installed the latest litecoin wallet on my windows machine and added the file and renamed it wallet.dat and the client updated including all the coins in the wallet. Problem is the wallet is encrypted, its asking for the wallet passphrase when i try to transfer the contents of the wallet. Is there anyway around this?



didn’t the latest version had issues with file format being too old?

Without the passphrase, you cannot move the coins, since passphrase is used to store an encrypted copy ofthe pprivate keys.

You could try brute forcing it, if you have clues on what the passphrase could be.


I manged to open a 2013 wallet.dat file with the current wallet software and it worked fine. it rebuilt and found all my coins. when i tried to transfer them out that’s when i got stuck with the passphase prompt.

I tried getting hashcat to find the keys to bruteforce them, but it doesn’t seem to be able to locate them in the wallet.dat file. I opened the wallet.dat file inside atom but couldn’t really work out what was going on in the file or anything that looked like a hash…so kinda stuck.

Got some mining GPU available that i can re-task to do the cracking but i can’t locate a hash.

You could use bitcoin2john to extract the hash from wallet.dat

I think this is it

python wallet.dat > wallet.hash
after that, you could hashcat with mode 11300 (IIRC) over the wallet.hash file

Cheers, will give that a try…

1 Like