Forgot Wallet Pass HALP!


I have the same issue as the OP, for the life of me cannot remember my pass phrase. But I think I have some sort of idea of the various words used (i think). I’m willing to part with a couple LTC if this pass phrase can be recovered.
Also tried to PM directly but I’m not seeing the message option. Maybe due to being a new account?


click on the user name you are trying to message then it will give you a private message link to click on


Hi ,i lost my password too, can you tell me where can i find the wallet recovery service ? thx thx thx:joy:


hashcat download site

how to use hashcat video

if you would like me to crack the password for you with my GPU…send me a personal message and I will get back to you ASAP…be sure you are willing to send me your backup file…if you have your address’ you can see all spends on block explorer’s to insure i wont steal your coins…I do charge by the hour for running my GPU for brute force and for dictionary…(less time for dictionary attacks if you have a close idea as to what your password might be)


Hi cxop. Sorry to dredge up an old thread. I too have forgotten my litecoin passphrase. This thread has inspired me to try hashcat on my Win10 PC at home running an R9 fury x. I’m hoping that’d be enough to put good dent in brute forcing a solution before I finally throw in the towel on my possibly lost litecoins.

Did you have luck with hashcat? If so, i’d love a bit of help on how it is I set it up on my PC. I’ve viewed a few videos and threads on various forums, but admittedly, it’s not clicking with me just yet. I downloaded the hashcat binaries, but am not sure what my next steps are. Any help in getting hashcat up and running would be hugely appreciated.


No need to be sorry.

Do you remember any aspects of your password? If you have a rough idea of what it probably was or at least what it contained, I’ve found that hashcat is a good solution. If you have no idea at all, it’s pretty bleak. The successes I’ve had with it were all cases where wallet owners knew some general aspects about the password.

If that is you, let me know and I can point you toward the details about extracting the password hash and setting hashcat loose on it.


Thanks for getting back to me. I have some really vague ideas of what might have been in the password. But I understand that bleak is probably the correct descriptor for my situation. That said, I have the hardware to brute force, so figured I ought to at least give it a try before giving up.

Any help with details is really appreciated.


one thing you can try…it will take a long time but it will eventually find it since its a simplified “brute force method” is “masking”…
if you know how many characters are in the passphrase you can tell hashcat or john the ripper to try all possibilities of say a 10 character phrase with the mask of l?l?l?l?l?l?l?l?l?l? in john the ripper that means to try all lowercase characters in a 10 character phrase…or ?u?l?l?l?l?l would do first letter uppercase and the next 4 lower case…just examples but try masking first if you have a general idea…

if a word has 5 characters and there are 10 possibilities of those characters then there are 5 to the 10th power of possibilities for that password…just an example but this should give you an idea how long it would take due to how many tries your machine has to do


Thanks for the tip, bakd247. I really appreciate it. Admittedly, I don’t recall how many characters long the passphrase is. My vague recollections can only conjure up a couple of characters at most. There are some phrases I would try, but not because I know they are part of the passphrase. Rather because they were phrases I used to use on passwords back during the time I created this passphrase.

I’m almost certain I created a completely random mix of characters. I think I remember 1 - 3 of those characters. But not more than that. And I don’t know the order in which I used them or the total length of the passphrase.

At this point I’m hoping to just get started with properly configuring hashcat so that I can try my vague guesses. I’m sure it’s not as simple as that, but any help getting me configured to run hashcat would be awesome.


you can also try making it print “candidates” for the hash…which may get you close to the password…then use “combinator” method in hashcat to try different methods of those words…if its not an actual word and you know this then word lists will be no help an masking with combinations may be your only options

I would start a 3 characters… you can also do a mask of all characters so start with 4 characters long and go up from there after its done…be warned each method takes a lot of time unless you only include ASCII characters…then again brute force always takes a lot of time…best to use with a GPU
This is the method I am currently using for a customer who forgot their password…I start at 9 characters…when that’s done I go to 10 then 11 and stop at 14 because we know its for sure between that…


hello can I get some help with my wallet.
I cant send a message to you because I don’t see how.
I lost my pass for my litecoin wallet.
I have some word that could be in the password.


if your a new user on litecointalk you cannot message anyone directly form the page…if your not a new user click the persons ID badge…then click message…or click your username at the top of the page…then click the little envelope…this will bring up your messages…then compose a new message to the username of your choice.


Question for you. How in the world do you extract your litecoin passphrase hash? I’ve spent several hours over the past couple of days trying to find this answer and have come up with very little.

That said, the more I read about it, it does sound like a mask attack is going to be my best bet.


download python
download john the ripper
run on your litecoin data directory specifying wallet.dat as your file name and ~./litecoin (in linux)(appdata in windows) as your application data folder


Okay so I’ve been messing around with this for days. I’ve installed all of the latest software as directed by the btcrecovery page. I’ve got python and johntheripper installed and all of the other things they require. Seems like I’m good to go, right? I open up my cmd prompt and run “> wallet_copy.dat” but all I get is a text file pop up that seems to be showing me the code that is supposed to be executing but isn’t. no copy of my wallet is made with a hash in it. Just a text file with lots of instructions but nothing executed on. Any thoughts on what I’m doing wrong? Who knew getting that password hash was going to be the bane of my existence?


no your doing it wrong…you cant point it at any random file…it needs the actual application data file in place and to be pointed at that
make sure the wallet your trying to crack is the wallet litecoin-qt opens up with…as in make sure in your application data folder that that “wallet_copy.dat” is in your appdata folder and renamded wallet.dat…replacing a blank wallet.dat file

ok now we have a working litecoin-qt core client that opens up and syncs with your coins in it right? and you just need the password…

now run john the ripper
assuming you have python installed already
open command prompt
cd (location you installed john the ripper)

once you are at the location you installed john the ripper in command prompt

type this in linux:
python ~/.litecoin/wallet.dat

if your using windows type it like this:
python C:\Users(currentuser)\AppData\Roaming\Litecoin\wallet.dat

this will return a string that is your password hash…then you copy paste that into a text file and name it something

then run john the ripper like this in linux (kali linux is best for this):
john ~/savedtextfile.txt l?l?l?l?l?l?l? for 7 characters all lowercase

in windows:
johntheripper.exe (pathtoyourtextfile)
or python (path to your text file)

johntheripper.exe --help
python --help
for all option for cracking passwords
john --help
in kali linux

another option that works for extracting is to replace your backup.dat file with a bitcoin-qt wallet.dat file in the appdata folder of a bitcoin-qt core wallet…renaming it wallet.dat of course
and the run
in command prompt once you cd to the location you have john the ripper installed as well…(hopefully you already know the part about command prompt to cd(change directory) before you can run a command or file)

again just make sure you are navigating to the folder you have john the ripper installed in while in command prompt before running the program


This is where I’m getting stuck. When I try to run “python C:\Users(currentuser)\AppData\Roaming\Litecoin\wallet.dat” it comes back with ‘python’ is not recognized as an internal or external command, operable program or batch file.

Do i have to have Python installed in the John the Ripper directory?

If I run the same line, less ‘python’, that’s when I just get the notepad file that pops up with gobs of code.

I agree. I must be doing something wrong.


thats because you are running python as an administrator but have it install under a user folder…
you need to install python for all users

possibly need to change “compatibility options” for john the ripper by right clicking johntheripper.exe and selecting compatibility…change it to same for all users…

do the same for python


So I’m running JohnTheRipper bleeding jumbo. I’m not finding a johntheripper.exe or any applications inside the johntheripper directory or sub folders. Searching for it doesn’t locate it either. Am I looking for the wrong thing?

As far as python, when I right click on the “application->properties->compatibility” the box for “Run this program as an administrator” is not checked which leads me to believe it is already installed for all users. Is my assumption correct?


Just to close out here, I seem to have gotten the hash now. Something was up with my python install. Adding a pointer to python.exe in the command fixed it.

Thanks much for all the help. Step 1 done! Now all I need to do is learn how to use hashcat :expressionless: