Electrum wallet problem

Hi,

I am trying to use the electrum ltc wallet on linux but it gives an error: “Warning: package scrypt not available; synchronization could be very slow” The wallet is so slow that its not possible to use it.

However, as far as I can see I have installed all necessary packages that are mentioned in the readme file.

I also tried to use the app image instead but it says “unknown file type” when trying to launch it. The btc electrum wallet + app image works fine.

Any idea how to solve it? Thank you.

Uhm. Thinking maybe you should try a package update and check you have all dependencies. Do you have a package manager in your distro? Like synaptic?

Would need to know more, like your distro, and how you ‘installed’ as it were the electrum ltc wallet.

Got a release from github? Curl? An ‘app store’ within your distro? Missing some steps here.

You obviously are doing something right as the btc electrum wallet works.

What do you mean by “package update”? My system is up to date and I have also run

sudo apt-get update
sudo apt-get upgrade

I am using Linux Mint 20 “Ulyana” - Cinnamon (64-bit), yes I have synaptic.
The electrum ltc files I have downloaded from electrum-ltc dot org (I cant put links as new user) - I verified the signatures.

Edit: It seems I fixed it by doing the following:

sudo apt-get install python3-setuptools python3-pyqt5 python3-pip python3-dev libssl-dev build-essential

pip3 install scrypt

(the app image still doesnt work though)

Hurray for the fix!

Seems maybe your distro ran on python 2 until you apt-get 3… never heard of this errror before, so learning here as well.

AppImage software works for me about 50% of the time. Prefer apt and building from source. Many different methods, same(ish) result

‘I verified the signatures’

Bravo, really, can’t tell you how many times I have seen people skip this step

By package management i mean looking into the packages (core and dependencies) of the electrum-ltc

To do this synaptic or another package manager is needed, sudo apt-get update does not always fix things such as broken dependencies or old repository sources.

More control with synaptic, also being a GUI helps. Here is an article you may enjoy on the subject

Understanding Packages, Repository and Package Manager in linux | The Coders Blog