Electrum-LTC not working any longer with Ledger after LTC app update

Hello :slight_smile:

I have been using Electrum-LTC with Ledger for the past few months without any issues. Reason being that the gap_limit in Ledger is ridiculous low even in developer mode(999), so most inputs are not visible.

A couple of days ago I updated the LTC app on my Nano X and since then, Electrum-LTC cant find any Ledger device anymore. It shows the following:
image

My device is plugged in and in LTC mode. Electrum (BTC) is working just fine.

Is there any way to access the funds without having to enter my seed on a device? Guarda Wallet doesnt work with Ledger (LTC), it never worked.

Sorry for the ping but maybe @losh11 as a note for you. Ledger couldnt help me so far.

A recent Ledger firmware update seems to have broken support for Ledger’s to work with Electrum-LTC. Please report this to Ledger support, making sure to let them know that it used to work before you updated firmware.

1 Like

Already done it and they are looking into it. I dont have high hopes. But we might get surprised. Guarda Wallet for example never worked even before the firmware update.

Litecoin App/Firmware on Ledger: 2.4.1

I wouldn’t be surprised if the cause of this issue is that eletrum-ltc hasn’t been updated for quite a while.
Ledger probably assumes that electrum-ltc uses the same “api settings” as electrum, hence copy-pastes the btc app settings to ltc app (with some changes). But as electrum-ltc development has been stale for a very long time it is possible that an essential update in electrum is missing in electrum-ltc, hence rendering an updated ledger ltc app update incompatible with (the outdated (compared to electrum) code in) electrum-ltc.

It’s already a pity that electrum-ltc hasn’t got MW support, but that it apparently isn’t developed at all anymore (even though litecoin foundation more or less officially took over maintenance of the project from pooler - Is this still maintained? · Issue #306 · pooler/electrum-ltc · GitHub) is really sad - at least there are no new commits on github since 10 months ago.

Your best best in the short run would ironically be a nano s because it itself it outdated and doesn’t get any updates from ledger…

1 Like

I have this same issues @lt-user

Any update? No news from Ledger. No alternative wallet for Ledger devices. Funds are basically “locked” away.