Connection to testnet - Connection refused

Hi all,

please is here someone who could help me with connection to LCT testnet ?
It seems that I can not connect to it and I am getting error:
connect() to failed after select(): Connection refused (111)

I have the latest Litecoin core daemon for linux and windows but I can not connect to testnet.

Thank you,

connection is more than likely being refused by your firewall either on your computer or on your router…if your behind NAT you can try running your own DNS server client to get around it or just enable it in your firewall…I never turn off my firewall but thats just me…

Thank you for the tips but:
I do not think that it is a DNS issue as the DNS seeds are retrieved else I would not see the IP address.
I do not think that it is a FW error as the nmap show the port as closed and not filtered.
C:\Users\rrunner>nmap -p 19333 -Pn

Starting Nmap 6.49BETA6 ( ) at 2017-04-11 23:50 Central Europe Summer Time
Nmap scan report for (
Host is up (0.012s latency).
19333/tcp closed litecoin

Nmap done: 1 IP address (1 host up) scanned in 0.66 seconds

This would mean that the end point was reached but the port is closed (service not running).
Same result for all the other nodes which I tried out from google search…

My FW is blocking only all incoming TCP connection and this would be a outgoing.The LTC wallet can connect to the ordinary network on port 9333. I can not connect only to the testnet of Litecoin…
Please has anybody more hints what could be wrong ?


1 Like

Testnet v3 is being depreciated and being replaced by v4. To use testnet v4, compile from the master or 0.14-dev branch of Litecoin Core.

Thank you, the compiled wallet is working with testnet4.