Cant get litecoins off my wallet

Please help. Been at least 6 hours trying to figure out how to get my litecoins of the wallet I created at

The page states “Spend your litecoins by going to and sweep the full balance of your private key into your account at their website.”

I can’t see an option like that at

I registered at also and only seems to be bitcoin option.

Please, need something simple like myetherwallet page where I just paste my private key in and have an option to send credit to a wallet address. But for Litecoin. It’s driving me nutzzzzzzzz Never spent so much of my time trying to figure something out that should be simple.

you have to “sweep” the private key form that liteaddress address…so whatever the private key is…open litecoin core…and once it is completely synced open help tab and click console then type importprivkey (private key here) and you should be good to go…btw its only simple if you have experience doing it…once you do it a few times its like riding a bike…problem is there is no instruction manual on using key managers/wallets at all…other than wiki pages

So your saying I copy the 51 character private key and past it in a box on a site called
Have I got that right?

Trouble is when I go to that site I always get a blank page with message “unable to connect”

If I could get the actual page then that would be a big step in the right direction.

I did a wiki on litecoin core and it has a link to this app but when I do click to download the app for Android all I get is “Oops! That page doesn’t exist or is private.”

Tried it on Windows but seems to want to download the whole blockchain, I have little internet bandwidth. I just want to send coins off my wallet not study the block chain using my bandwidth up on pay as you go.

Litecoin will never be successful if can’t make a few simple apps to allow people to send the coins off their wallet. Were not all geeks. There are few apps on android but all I have tried look crappy and they only allow viewing of the wallet content.

My coins are still stuck on my wallet. Wish I had never converted my ETH to Litecoin now.

Try this wallet instead.

If you have an iPhone, you can spend your coins though LoafWallet.
Open the app and select “import private key” and scan the QR code labeled private key.

1 Like

I wouldn’t recommend sweeping private keys with anything but core wallets…just open console and type importprivkey (followed by private key) and then importaddress (followed by address) then start with -reindex and -rescan flags

Thanks for the help guys (or girls).

Have managed to sort it out now after 8 hours. Now I can relax. :slight_smile:

I ended up using Exodus on Windows to transfer the Litecoins. Strange software. They have the important import funds option only show when you press shift+ctrl+D

Have a nice day.