I tried to restart my litecoin core, but it failed

2021-03-05T05:43:24Z Litecoin Core version v0.18.1 (release build)
2021-03-05T05:43:24Z Assuming ancestors of block f19dfbdc0e6c399ef45d315d89fc3e972dd8da74503252bacaf664f64d86e6f6 have valid signatures.
2021-03-05T05:43:24Z Setting nMinimumChainWork=0000000000000000000000000000000000000000000000000035ed7ece35dc93
2021-03-05T05:43:24Z Using the 'sse4(1way),sse41(4way),avx2(8way)' SHA256 implementation
2021-03-05T05:43:24Z Using RdRand as an additional entropy source
2021-03-05T05:43:24Z Default data directory /root/.litecoin
2021-03-05T05:43:24Z Using data directory /root/.litecoin/testnet4
2021-03-05T05:43:24Z Config file: /root/.litecoin/litecoin.conf (not found, skipping)
2021-03-05T05:43:24Z Using at most 125 automatic connections (1048576 file descriptors available)
2021-03-05T05:43:24Z Using 16 MiB out of 32/2 requested for signature cache, able to store 524288 elements
2021-03-05T05:43:24Z Using 16 MiB out of 32/2 requested for script execution cache, able to store 524288 elements
2021-03-05T05:43:24Z Using 4 threads for script verification
2021-03-05T05:43:24Z scheduler thread start
2021-03-05T05:43:24Z Binding RPC on address 172.17.0.5 port 19332 failed.
2021-03-05T05:43:24Z Unable to bind any endpoint for RPC server
2021-03-05T05:43:24Z Error: Unable to start HTTP server. See debug log for details.
2021-03-05T05:43:24Z Shutdown: In progress...
2021-03-05T05:43:24Z scheduler thread interrupt
2021-03-05T05:43:24Z Shutdown: done

Is it possible you already have it running?

I have solved this problem. it’s seems that the IPAddress of my docker container changed. so I set the value of rpcbind to the new IPAddress, then it started successfully.

glad you were able to fix it!