Fixing and hacking KNC Titans and MAT miners because they break from time to time

I have 24 Titan KNC cubes to sell total hashing power 1100mh/s. Urgent Moving in a small apartment downtown.


Hi, I have already tried to contact you via another post.

I have a Titan miner that currently does not see the cubes. I have had the same problem already and I just replaced the Raspberry Pi. Now this does not work.

The Pi still works, I can ssh into it. Maybe just the GPIO are defective, maybe the controller board is defective.

I have bought GenTark’s firmware but it does also not work.

Another problem was, that there are multiple versions of the RPI B+. I did upgrade the system and then I could boot with the replacement RPI, but it still does not work. So it is probably the Controller board.

When I look at the logs I see an error message I2C lock failure #1 #3 etc.

Do you have any suggestion what to do? Or could you repair it?

Yep, I can repair it. You can check the controller board by logging in as root and executing this command

io-pwr init

If it doesn’t come back with a one line success message then the FPGA and possibly the TPS power chip is bad. They can be replaced.

As for the Rpi issue, I spent a lot of time building the code needed to make a beaglebone black work with Titans, the code is free at:

Download it to a 4gb or better SD card username is pi/admin, root/admin, and of course for the web site admin/admin. What the hell, I am not creative.

But I do request a week’s worth of mining or 5ltc donation. Optional of course.

Anyway replied to you privately, hope we can get this fixed.

Hi Lightfoot!

I think you might just become my newest hero. I just purchased a bank of 4 used Titan ASIC cubes. I bought them so I could learn more about crypto, mining and the beautiful technology behind it.

One of my cubes (well, 2 actually) are misbehaving. I’ve been toying with the voltage/speed settings a bit and can’t quite get it to stay stabilized. Not sure if this is a software or hardware issue. I’ve seen all the dies work in the cube. At any rate, I’d love some help and advice that I’d absolutely be happy to pay you for. Still learning and super eager to do it. I’ve got an electronics background but still some of this is over my head.

new to this forum, could not figure out a way to PM you, so posting here. Is a remote screen session possible?

Interesting. This might be a loose heat sink, take the top off the cube and see if you can wiggle the sink by rotating it a bit. It should be firm, if it wobbles then take the sink off, re-paste it, then put on the screws and snug them all down. If it still wobbles you need three very small washers, one under each screw. Snug down carefully (you can bend the board or break the chip with too much force) goal is to snug it down to the point where you can’t wiggle the heat sink on the die. That is enough.

Then run at 50mhz for a bit, then speed up. Temps should never go above 44-45 on the chip.

ugh. all of these things run over 45 easily on all chips. i’m sure that they all need a re-paste. Usually on a re-boot they will all work but fail within minutes. I even have a powerful blower fan which is providing super ample airflow in a cool basement setting.

so what needs re-pasting? just the heat sink?

Yep, the heat sink and die. I recommend cleaning off all the factory stuff KNC used and use a non-conductive heat sink compound. Put a finger-thin coating on the die, same on the heat sink, then connect them up.

Some people stick heat sinks on the power supplies, but to be honest I recommend just keeping the power down a bit on those to stop overheating.

Yeah, these things need some new paste and cleaning is my guess. This guy actually modifies the heat sinks

I did take them apart, cleaned, repasted and reassembled. They all are showing on the GUI to be humming along and showing good current draw,however Litecoinpool is displaying a very low hash rate. Now I’m worried I messed something up.

Also, are you wallet addys in your profile? I owe you for your quick replies and help

Oh good. Litecoinpool sometimes takes a bit to catch up on the latest rate, can you check the home page to see the hash rate, if you want details you can log in as username pi and type

screen -r

to see the bfgminer screen. Pressing d then m will bring up the individual dies, look through and see what each one is doing.

@lightfoot - what do you think and feel about placing the entire Titan in an aquarium of mineral oil and pumping the mineral oil through a large auto radiator (and oil filter) with a fan to cool it. I want to really ensure everything is cooled. Do you see any problems with that?

Yes. Mineral oil will not be able to pull the heat away fast enough and the chip will blow up. People tried this with other miner technologies and the results were bad. There is a type of coolant people were using to cool earlier chips, but it’s really kind of overkill. Besides if you pour on the power you will just blow up the PCIe power connector.

Best bet is to ensure the heat sink is on snug, use a good thermal compound, run the older and somewhat louder fan, ensure the shroud is on and screwed down, and don’t run it much above 250mhz-275mhz per die with all four dies running. That should get you 65-70mh per cube which is optimal.

I did put a water block on a Neptune for awhile, it was cool until the block suffered a pump failure and exploded. The more complex the technology, the easier it is to stop up the drain.


Would you happen to have any cubes for sale? I’m thinking of getting 1 or 2 extra. I have 4.

Unfortunately no. I mainly repair cubes, I don’t keep any for day to day mining.

Well, there’s always something new. Got two cubes in today for repair. One had a burned plug (fixed, I need to order another box of plugs) with all four dies now working. The second one was weird: The user said it would start mining then shut down the whole contoller within a new minutes. So I hooked it up, put a good heat sink on it, and took a look.

Interesting one. Very, very interesting. Yes, it does come up on four dies (one supply is bad on die 1) and yes it does crash the controller and in one case shut down my power supply. Never seen this one.

Did some work on it. Die 1 is bad. It works, but it’s still bad, what happened is that it overheated and damaged both its power supply and the rest of the board to some extent. In this case, when it comes up it goes into thermal runaway as it heats up, ultimately shorting the supplies and the board. You can see the burning on the back of the board, it got very hot.

Turning it off clears that but the other three dies also run very hot. After experimenting for a bit and doing a reflow I found a solution: Run the remaining three dies at a much lower voltage. Running dies 2,3,4 at -.0806 at 275mhz gives you a cube that runs at 57mh while running at 42c in a box with the original style fan. That’s a pretty good running cube and about what you should expect from a cube normally. So that’s fixed as well.

Never know what you will run into in this business…

Hi There

I have 20 cubes for sales total hashing power 1200mh/s. Serious BUYER ONLY! @lightfoot repairs some of them in the past.


Hi @lightfoot I have a few cubes with different kinds of problems.How can I contact you for repair?

You can PM me on this forum, click my name and send me a message with the details or write it here and I’ll let you know if they can be fixed.

I don’t have enough right to PM I think. :confused:

I have a few cubes where some of its dies not working properly. I can see that they are drawing power (voltage, current, and power) but only very little (current and power 0.x~1.x A / W). It never comes up to normal values since startup so it doesn’t seem to be too hot and being shut down for cool down.

Another problem is that for one of the cubes the little square (I think it is the capacitor?) around the die was exploded (and burnt).

Then I have one cube where all dies are working fine but the temperature of half of them keep in very high, which makes the controller continuously shutdown those dies for cool down and restart. I checked that all contacts among the rubbers and heat sink should be good. I’m not sure if it is problem of dies.


Sounds like some blown drivers and the like. Probably fixable, I’ll send you a PM in a moment here. If you feel comfortable removing and replacing the heat sinks it makes the shipping a lot more simple to do :slight_smile:

I have 3 modules that are not working properly. The 1 modules are completely broken and the other 2 modules work half way. How much is the maintenance fee and mailing address? Can I send UPS in China?