Error reading from database

Hi Team,

I am new here and this is my first post, so please go easy on me as I am a newbie to all the crypto terminology. I am in the process of trying to upgrade my wallet to the latest version because I had the COMPROMISED WARNING so I have saved the dat file and uninstalled the old LTC wallet and downloaded the new version. The problem I am having is when the new wallet opens, it starts synchronizing and is 15 weeks behind, about 3 or 4 minutes later I get a “Error reading from database, shutting down” message. Once closing that window another window pops up and says " Runtime Error! This application has requested the Runtime to terminate in an unusual way. Please contact the application’s support team for more information"

Can anyone help me here as it’s done it about 3 times now and it’s quite frustrating.

Kind Regards

you need to start it from command prompt with the -rescan flag…

or open the wallet and click help then debug window then console and type reindex in the box and when that’s done type rescan in the box or: even easier option is to click your start bar then search for “cmd” which opens command prompt…find your litecoin saved location by right clicking the desktop logo and clicking “open file location” then right click the address bar and click “copy address as text” and then open command prompt

to start from command prompt copy and paste the location you have litecoin saved at into command prompt and once you “cd” to that folder start litecoin with this command: litecoin-qt.exe -reindex -rescan

Ok I did that and I thought I was making progress, the wallet opened and it started Reindexing blocks on disk and got through the whole 5 years and 47 weeks but once it started Processing blocks on disk I get the runtime error with still 5 years and 42 weeks behind. I tried this 3 times and it crashed with the same error all 3 times when it started Processing blocks. Where do I go from here?
Thank you for all your help so far, I very much appreciate it.

what does the debug file say at the bottom of it when it crashes? located in appdata folder
could be a memory allocation issue

You are right, in the debug notepad right down the bottom it says I am out of memory. Terminating.
I am running XP and have 2.92G of RAM, is this not enough? What are my options other than installing more RAM?

it all depends on what your machine is allocating the memory for…try doing a memory diagnostics Start…windows administrator tools…memory diagnostics…see if oyu can free up some ram by defragging the ram…2gb should be enough…but if your machine is using it for other stuff then you don’t have enough left for litecoin…

Ok i have tried that with my current laptop and I still had the same outcome. So rather than buy more ram for my old laptop I decided to just buy a new one and got a dell with 8gb ram and a 128ssd drive. I have downloaded the latest version of Litecoin core wallet and was hoping to just upload my data file that I had saved from my old machine but I guess it doesn’t work like that as it wouldn’t allow me and said that my old file was too big GRRRRR!
This is so frustrating, any tips on how to do this or do I need to add more RAM to my old machine and get the old wallet working?

no…do a RAM diagnostics using windows administrator tools “Memory Diagnostics”…also check your bios by pressing either F2 or ESC when you boot your computer and make sure the BIOS shows all memory sticks running at full clock

another option for diagnostics of RAM is Kali Linux…which contains diagnostic software with the loadable drive version…
anyway…RAM isn’t that expensive but I wouldn’t go replacing it unless you know you can add more to your machine…are you running 1600 1850 or 2100 MHZ RAM? Are you able to add more Available Ram to the system? some BIOS on Laptops like mine will only allow for a max of 8 GB

you only need 2 GB for litecoin to work…I think you have another pricess taking all your ram when your running litecoin…
close everything except litecoin when you run it
The “Available RAM” that programs and applications can access is what you need more allocation of or just more of…
What kind of Laptop is it?

I ended up fixing this by transferring the dat file to my new machine and all is working fine now. I do have another problem though with the Loaf Wallet on my iphone, the transaction is unverified and has been for a few weeks now, I had a .002 transaction fee set but I think there may have been some abandoned or conflicted coins in the transaction. Does anyone know how to cancel a transaction in the Loaf wallet as I have looked everywhere in the app and it doesn’t give me any option to do so what so ever.