Can't get Litecoin wallet to be created and synched on two different OSes


This is my first post and the problem I have had is very frustrating.

I have two laptops and thought of using one to mine Litecoins (yeah, I know about the lack of power laptops have but I want to still go ahead and do it anyway). So I downloaded the latest Litecoin wallet build and also the litecoin bootstrap file that cam in at over 3GB in size. I followed all the instructions about where to place the bootstrap file started the litecoin application and then found that after many hours (over a day) the application crashed at around the ‘5yrs and 32 weeks behind’ mark. I found that the dll that was causing a problem was the msvcrt.dll one, so I did a system file check scan and then restarted my laptop, started up the litecoin application and tried again. It crashed at the exact same point with the exact same problem.

Thinking that it was an OS issue I installed Windows 7 on the laptop (it had Windows XP SP 3 on it) and spent quite a bit of time getting everything up and running again. This is now going onto the 4th day!!!

I started the app and it crashed again. I went through the process of restarting the laptop and restarting the application and again the exact same thing happened. This time I was able to get a screenshot of the freeze occurring and found that it was crapping out at exactly the same point in time as all the other times.

It seems, from all the stuff that I have read, that there is an invalid transaction that is screwing up the wallet.

How can I get this stuff to work if this is going on?

I have spent quite a lot of time on this so any help would be appreciated.

The laptop has a 3.2Ghz Pentium 4 with 2Gb of memory and a 130GB HD with 110GB free. The bootstrap file IS in the correct location.

you have an Intel so make sure you are using the 32 bit version…
64 bit versions are AMD
I had this same problem…now I installed the 32 bit version and all works perfect…make sure you are running the 32 bit OS on your machine too

intel i-5 and i-7 are 64 bit though but the 64 bit versions of bitcoin and litecoin wont work right…still need a 32 bit version for that one too

Hi, Yes I do have the 32 bit version of Litecoin installed. And the OS is also 32 bit. Litecoin refuses to go past that 5 year 32 week mark though when synching …

then you are either out of disk space or dont have the latest version installed…
what does the debug log file say at the very bottom after you get the error?
open “help tab” and the Console to see the debug log file under “Information”

It says

Error: Out of memory. Terminating.

The interesting thing is that between the last ‘UpdateTip’ and the error, 36 seconds elapses. Normally there are multiple instances of these UpdateTips per SECOND. UpdateTips prior to the error were 4 per second, next second back 8 per second.

Here’s the thing though this happens at exactly the same point on whichever machine I try and install it on. I even tried to install it on my other laptop (a Win XP SP3 machine with 2GB of RAM and 1TB HD) and the exact same thing happened. If the exact same thing happens on two different machines and with two different OSes then it is NOT my laptops that are at fault.

After starting Litecoin again I checked the memory usage and it is on average 36%, with CPU usage at 65%. No other installed programs are running apart from Notepad and Task Manager and the usual background services.

I even stopped my Anti Virus without much change in these figures.

But as I watched the task manager settings I did notice that litecoin-qt.exe’s memory usage was consistently going up. AS I write this physical memory is at 42% and rising. Synch is at 5 years and 48 weeks. I will wait to see what happens when it hits 5 years and 32 weeks…

I just watched the whole thing crap out again. CPU was at around 69%, physical memory was at 51-52%. I even filmed it with my digital camera.

It came up with the error message to do with Microsoft Visual C++ Runtime Library:

‘This application has requested the Runtime to terminate it in an unusual way.
Please contact the application’s support team for more information.’

The debug window message is the same as before: Error: Out of memory. Terminating.

The litecoin program is the up-to-date one: v0.14.2

It terminated on Last block time of: Thu Mar 15 08:11:11 2012

if seems to me like your generating blocks to be mined is the only reason the cpu would jump up like that when you run it
however it should not be doing that if the chain is not synced yet…

do you have a .conf file saved in the appdata folder? if so then delete gen=1 form it…or just delete any .congf file you see in the appdata folder and restart litecoin and see if that fixes it

or you can open console and type setgenerate true or generate true…type help to see what the generate blocks command is as I forget off the top of my head right now…

Hi, I just looked in both the App folder under Users/[me]/AppData/Roaming/Litecoin and the program folder and there was no conf file before or after the program was started.

Is this normal?

yes you only need one if you are mining with the wallet…
Error: Out of memory. Terminating. means you need more RAM for your computer to run the application
run a memory diagnostics under windows administrative tools