Can't get Litecoin wallet for mac

Hi, I have a macbook pro 2011 with the latest osx on it. I have tried several times to download and install the wallet but it doesn’t work. Error network, no datas to download. I have a back up but I can’t use it without the wallet. Can someone help me ?

if it is showing a network error then your firewall is not allowing incoming connections and your wallet will not sync unless you allow incoming connections to your node…
try this …open the wallet and under options select “Map Ports using UPnP” then restart the client (wallet)

Thanks a lot for your answer but my problem is not there. I can’t reinstall the program on my computer. I mean the wallet… it doesn’t work and i don’t know why.
I’ll try several links but at the end, none were working…

Hi! Are you using this wallet ?
People also say that Jaxx works nicely on MacOS and iOS

Thanks for your answer. I have tried with Electrum but it says that it can not read the file (.dat). I used to have LTC core from but I can not install this wallet on my macbook pro 2011 with High Sierra. It says that I don’t have the rights to do that. I am still the administrator. So I have a backup in my computer with a dat. extension but I can’t use my backup because I can not install the proper wallet… Can you help me with that ?

I have the same issue but I gave up after trying several times

electrum will not read a core wallet .dat file…you have to use a core wallet in order to parse the information correctly…
you can always dump your private keys using pywallet and your password and then just import your keys to a new working wallet